杭电5138-CET-6 test

Problem Description

Small W will take part in CET-6 test which will be held on December 20th. In order to pass it he must remember a lot of words.
He remembers the words according to Ebbinghaus memory curve method.
He separates the words into many lists. Every day he picks up a new list, and in the next 1st,2nd,4th,7th,15th day, he reviews this list.
So every day he has many lists to review. However he is so busy, he does not know which list should be reviewed in a certain day. Now he invites you to write a program to tell him which list should to be reviewed in a certain day.
Lists are numbered from 1. For example list 1 should be reviewed in the 2nd,3rd,5th,8th,16th day.

Input
Multi test cases (about 100), every case contains an integer n in a single line.
Please process to the end of file.

[Technical Specification]
2≤n≤100000

Output
For each n,output the list which should be reviewed in the nth day in ascending order.

Sample Input
2
100

Sample Output
1
85 93 96 98 99
思路:其实这道题想明白了,很简单,就是一个记忆曲线,用输入的数减去15,7,4,1即可

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
	int n;
	while(cin>>n)
	{
		if(n>15)
		{
			printf("%d %d %d %d %d\n",n-15,n-7,n-4,n-2,n-1);
		}
		else if(n>7&&n<=15)
			printf("%d %d %d %d\n",n-7,n-4,n-2,n-1);
		else if(n==2)
			printf("%d\n",n-1);
		else if(n>2&&n<=4)
			printf("%d %d\n",n-2,n-1);
		else if(n>4&&n<=7)
			printf("%d %d %d\n",n-4,n-2,n-1);
	}
	return 0;
}
还有一种简单的方法

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        if(n>15)
            printf("%d ",n-15);
        if(n>7)
            printf("%d ",n-7);
        if(n>4)
            printf("%d ",n-4);
        if(n>2)
            printf("%d ",n-2);
        if(n>1)
            printf("%d\n",n-1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值