POJ1745Divisibility【dp】

 

Divisibility

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 11053

 

Accepted: 3953

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 717 5 -21 15

Sample Output

Divisible


 

题意:给出N个数通过在其中添加+-号问是否能计算出k的倍数

dp[i][j]代表前i个数余数为j是否存在

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
const int MAX=10010;
int dp[MAX][110];
int num[MAX];
int main()
{
	int n,m,k,i,j;
	while(scanf("%d%d",&n,&k)!=EOF){
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;++i){
			scanf("%d",&num[i]);
			if(num[i]<0){
				num[i]*=-1;
			}
			num[i]%=k;
		}
		dp[0][num[0]]=1;
		for(i=1;i<n;++i){
			for(j=0;j<k;++j){
				if(dp[i-1][j]){
					dp[i][(j+num[i])%k]=1;
					dp[i][(k+j-num[i])%k]=1;
				}
			}
		}
		if(dp[n-1][0])
			printf("Divisible\n");
		else
			printf("Not divisible\n");
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值