poj1269Intersecting Lines【直线相交平行共线的判断+求交点】

 

 
Intersecting Lines
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12542 Accepted: 5595

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.  
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.  

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

 

题意:判断两条是否直线相交,共线,平行相交输出焦点;注意是直线不是线段

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#define eps 1e-6
using namespace std;
struct point{
	double x,y;
};
struct line{
	point a,b;
};
bool equal(double x,double y){
	return fabs(x-y)<eps;
}
double operator^(const point &a,const point &b){
	return (a.x*b.y)-(b.x*a.y);
}
int findinter(point p1,point p2,point p3,point p4,point &inter){
	point vec1={p2.x-p1.x,p2.y-p1.y};
	point vec2={p4.x-p3.x,p4.y-p3.y};
	point vec3={p3.x-p1.x,p3.y-p1.y};
	double cross=vec1^vec2;
	if(equal(vec1^vec3,0)){
		if(equal(cross,0))return 2;
		
	}
	if(equal(cross,0))return 1;
	double cona=p1.x*vec1.y-p1.y*vec1.x;
	double conb=p3.x*vec2.y-p3.y*vec2.x;
	inter.x=(conb*vec1.x-cona*vec2.x)/cross;
	inter.y=(conb*vec1.y-cona*vec2.y)/cross;
	return 3;
}
int main()
{
	int t,i,j;
	while(scanf("%d",&t)!=EOF){
	line l1,l2;
	point inter;
	printf("INTERSECTING LINES OUTPUT\n");
	while(t--){
		scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&l1.a.x,&l1.a.y,&l1.b.x,&l1.b.y,&l2.a.x,&l2.a.y,&l2.b.x,&l2.b.y);
		int ans=findinter(l1.a,l1.b,l2.a,l2.b,inter);
		if(ans==1){
			printf("NONE\n");
		}
		else if(ans==2){
			printf("LINE\n");
		}
		else{
			printf("POINT %.2lf %.2lf\n",inter.x,inter.y);
		}
	}
	printf("END OF OUTPUT\n");
	}
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值