hdoj5478Can you find it【暴力枚举+快速幂】

Can you find it

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 980    Accepted Submission(s): 421


Problem Description
Given a prime number  C(1C2×105) , and three integers k1, b1, k2  (1k1,k2,b1109) . Please find all pairs (a, b) which satisfied the equation  ak1n+b1  +  bk2nk2+1  = 0 (mod C)(n = 1, 2, 3, ...).
 

Input
There are multiple test cases (no more than 30). For each test, a single line contains four integers C, k1, b1, k2.
 

Output
First, please output "Case #k: ", k is the number of test case. See sample output for more detail.
Please output all pairs (a, b) in lexicographical order.  (1a,b<C) . If there is not a pair (a, b), please output -1.
 

Sample Input
  
  
23 1 1 2
 

Sample Output
  
  
Case #1: 1 22
 

Source

用G++提交4700msc++提交超时

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
long long Pow(long long a,long long b,long long c){
	if(!b)return 1;
	long long t=Pow(a,b>>1,c);
	t=t*t%c;
	if(b&1)t=t*a%c;
	return t;
}
int main()
{
	int t,i,j,k=1;
	long long  k1,k2,b1,c;
	while(~scanf("%lld%lld%lld%lld",&c,&k1,&b1,&k2)){
		bool sign=true;
		printf("Case #%d:\n",k++);
		for(int a=1;a<c;++a){
			long long ans=Pow(a,k1+b1,c);
			long long b=c-ans;
			if(b>=1&&b<c){
				for(j=1;j<=10;++j){
					if((Pow(a,k1*j+b1,c)+Pow(b,k2*j-k2+1,c))%c!=0){
						break;
					}
				}
				if(j>10){
					sign=false;
					printf("%lld %lld\n",a,b);
				}
			}
		}
		if(sign){
			printf("-1\n");
		}
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值