hdoj5978Sequence I【kmp】

Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 604    Accepted Submission(s): 237


Problem Description
Mr. Frog has two sequences  a1,a2,,an  and  b1,b2,,bm  and a number p. He wants to know the number of positions q such that sequence  b1,b2,,bm is exactly the sequence  aq,aq+p,aq+2p,,aq+(m1)p  where  q+(m1)pn  and  q1 .
 

Input
The first line contains only one integer  T100 , which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers  1n106,1m106  and  1p106 .

The second line contains n integers  a1,a2,,an(1ai109) .

the third line contains m integers  b1,b2,,bm(1bi109) .
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 

Sample Input
  
  
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 

Sample Output
  
  
Case #1: 2 Case #2: 1
 

Source

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
#include<set>
using namespace std;
typedef long long LL;
typedef pair<int,int>pii;
const int maxn=1e6+10;
int a[maxn],b[maxn],Next[maxn];
void getNext(int n){
    int i=0,j=-1;Next[i]=j;
    while(i<=n-1){
        if(j==-1||(b[i+1]==b[j+1]&&b[i+1]==b[j+1])){
            i++;j++;
            Next[i]=j;
        }
        else j=Next[j];
    }
}
int KMP(int n,int m,int q,int x){
    int ans=0;int i=x,j=0;
    while(i<=n){
        if(j==-1||(a[i]==b[j+1]))i+=q,++j;
        else {
            j=Next[j];
        }
        if(j==m){ans++;}
    }
    return ans;
}
int main()
{
    int t,Test=1;cin>>t;
    int n,m,q;
    while(t--){
        scanf("%d%d%d",&n,&m,&q);
        memset(b,0,sizeof(b));
        for(int i=1;i<=n;++i){
            scanf("%d",&a[i]);
        }
        for(int i=1;i<=m;++i){
            scanf("%d",&b[i]);
        }
        getNext(m);int ans=0;
        for(int i=1;i<=q&&i<=n;++i){
            ans+=KMP(n,m,q,i);
        }
        printf("Case #%d: %d\n",Test++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值