【PAT】1101. Quick Sort (25)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

    Hence in total there are 3 pivot candidates.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

    Output Specification:

    For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

    Sample Input:
    5
    1 3 2 4 5
    
    Sample Output:
    3
    1 4 5
    分析:假设x为数列中的某个数,如果x大于左边最大的数,小于右边最小的数,那么x就符合入选条件。因此只要用俩个数组,来记录左边最大数,和右边最小数就行了。

    陷阱:如果最后的结果是0,那么输出0之后要再输出一个空白行,这绝对是个坑。

    代码如下:

    #include <iostream>
    #include <vector>
    #include <algorithm>
    using namespace std;
    
    int main(int argc, char** argv) {
    	int n,i;
    	cin>>n;
    	vector<int> vec(n);
    	vector<int> left(n);//左边最大的
    	vector<int> right(n); //右边最小的 
    	
    	int max=-1, min = 1000000001;
    	for(i=0; i<n; i++){
    		scanf("%d",&vec[i]);
    		if(vec[i]>max){
    			max = vec[i];
    		}
    		left[i] = max;
    	}
    	
    	if(vec.size()==1){
    		//如果输入只有一个数 
    		printf("1\n%d\n",vec[0]);
    		return 0;
    	}
    	
    	for(i=n-1; i>=0; i--){
    		if(vec[i]<min){
    		    min = vec[i];
    		}
    		right[i] = min;
    	}
    		
    	vector<int> out;
    	int maxLeft, minRight;
    	
    	if(right[0] >= vec[0]){
    		out.push_back(vec[0]);
    	}
    	for(i=1; i<n-1; i++){
    		maxLeft = left[i-1] ;
    		minRight = right[i+1] ;
    		if(vec[i]>maxLeft && vec[i]<minRight){
    			out.push_back(vec[i]);
    		}
    	}
    	if(left[n-1] <= vec[n-1]){
    		out.push_back(vec[n-1]);
    	}
    	sort(out.begin(), out.end());
    	
    	printf("%d\n",out.size());
    	if(out.size()==0){
    		printf("\n"); //要加这个回车,否则不能通过。真是坑。 
    		return 0;
    	}	   
    	  
    	printf("%d",out[0]);
    	for(i=1; i<out.size(); i++){
    		printf(" %d",out[i] );
    	}
    	printf("\n");	
    	return 0;
    	
    }
    
    
    
    
    


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值