【POJ 1456】Supermarket

Supermarket
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9560 Accepted: 4116

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

Source


贪心+并查集的应用~


首先贪心的来看,按照获利来排序,把每一个放在他能够放的最后一个位置。


那么怎么快速确定他能放置的最后一个位置?


用并查集~


如果i这一天被使用了,fa=Getfather(i)那么f[fa]=f[fa-1],f[i]表示f[i]+1到i都被使用了。


如果fa=0说明这个物品不能加入。


#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#define M 10000+5
using namespace std;
int n,f[M];
struct data
{
	int p,d;
}a[M];
void read(int &tmp)
{
	tmp=0;
	char ch=getchar();
	int fu=1;
	for (;ch<'0'||ch>'9';ch=getchar())
		if (ch=='-') fu=-1;
	for (;ch>='0'&&ch<='9';ch=getchar())
		tmp=tmp*10+ch-'0';
	tmp*=fu;
}
bool cmp(data a,data b)
{
	if (a.p==b.p) return a.d<b.d;
	return a.p>b.p;
}
int Getfather(int x)
{
	return x==f[x]?x:f[x]=Getfather(f[x]);
}
int main()
{
        while (scanf("%d",&n)!=EOF)
	{
		int mad=0;
		for (int i=1;i<=n;i++)
			read(a[i].p),read(a[i].d),mad=max(mad,a[i].d);
		sort(a+1,a+1+n,cmp);
		int ans=0;
		for (int i=0;i<=mad;i++)
			f[i]=i;
		for (int i=1;i<=n;i++)
		{
			int fa=Getfather(a[i].d);
			if (fa)
			{
				ans+=a[i].p;
				f[fa]=f[fa-1];
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


感悟:

1.WA是因为f[fa]=f[fa-1],一开始写成f[a[i].d]=f[a[i].d-1]


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值