myeclipse10下 Java compiler level does not match解决方法

原创 2016年10月10日 09:33:45

以前一直用myeclipse2014,忽然换到myeclipse10,很多项目到这里运行起来老是出问题,得总结啊。
compiler是编译的意思,在项目导入IDE的时候,自己选择编译器,编译器会构建ide的环境

并把这个编译的一些参数放入IDE工作空间下面的项目文件下面有一个setting文件夹,里面的org.eclipse.wst.common.project.facet.core.xml 文件的参数
形如:

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <fixed facet="wst.jsdt.web"/>
  <installed facet="java" version="1.5"/>
  <installed facet="jst.web" version="2.5"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>

这里的1.5就是你编译的版本。java的虚拟机是一种解释行的语言,那么要用相同的版本去解释,这也是为什么我用myeclipse10的时候编译和解释后再tomcat中发布老是说我的编译没有通过的原因。
让它与项目的编译器版本设置保持一致即可。
查看项目的编译器版本。
这就是myeclipse10中查看版本编译
没想到这细节在这个myeclipse10里面需要这么去注意。另外就是JDK的版本需要我们默认的设置成我们自己安装的,不然,一导入项目就会是IDE自带的,用惯了2014,这些细节还是有差别的。

版权声明:本文为博主原创文章,未经博主允许不得转载。

解决java compiler level does not match the version of the installed java project facet

java compiler level does not match the version of the installed java project facet错误的解决因工作的关系,Eclips...
  • chszs
  • chszs
  • 2012年10月29日 20:21
  • 139067

GOOD解决MyEclipse工具中java compiler level does not match the version of the installed java project facet

Java compiler level does not match the version of the installed java project facet错误的解决 因工作的关系,Ecl...
  • Baple
  • Baple
  • 2016年06月07日 10:35
  • 1108

Java compiler level does not match解决方法

从别的地方导入一个项目的时候,经常会遇到eclipse/Myeclipse报Description  Resource Path Location Type Java compiler level d...
  • u012506661
  • u012506661
  • 2016年10月26日 10:04
  • 3408

myeclipse里工程的jdk使用的1.7版本,其中java compiler最高只能选到1.6的问题(在maven工程中出现的问题) -- 记录

在工程里面,引入的是1.7版本的jdk: 但是在java compiler中最高只能选择1.6版本。百度了一些大都是说ide有问题。我查看其他工程发现改成1.7的jkd,java compi...
  • qq_16397481
  • qq_16397481
  • 2017年03月27日 10:35
  • 1322

myeclipse compiler JDK版本 工程JDK版本

 最近运行工程时报错:myeclipse Java compiler level does not match the version of the installed Java... ...
  • qiyejunlintian
  • qiyejunlintian
  • 2013年12月13日 23:54
  • 3060

Java环境搭建MyEclipse10+jdk1.8

一、安装JDK 1、下载得到jdk-8u11-windows-i586.1406279697.exe,直接双击运行安装,一直next就可以,默认是安装到系统盘下面Program Files,我这...
  • yy243
  • yy243
  • 2016年10月10日 10:30
  • 12876

myeclipse工程环境出错:Set project compiler compliance settings to '1.5'

工程编译出现问题,提示Set project compiler compliance settings to '1.5' 解决方案:右击项目-->properties-->java compiler...
  • dongfengkuayue
  • dongfengkuayue
  • 2015年11月17日 09:01
  • 6180

myeclipse10配置了jdk8,却用不了jdk8的新特性?

myeclipse开发时,保证编译时和运行时的jdk版本一致
  • qq_16568205
  • qq_16568205
  • 2016年11月19日 12:40
  • 6664

myeclipse工程有红叉,里面文件没错,提示Java compiler level does not match the version of the installed Java project

myeclipse工程有红叉,里面文件没错,提示:Java compiler level does not match the version of the installed Java projec...
  • washli2001
  • washli2001
  • 2014年03月11日 15:19
  • 902

java compiler没有1.8怎么办

1.打开eclipse->选择help->点击 install  from catalog 加载完成后,点击搜索 Java 8 : 选择第一个点击安装,安装完成后,重启eclips...
  • qq_36350532
  • qq_36350532
  • 2018年01月11日 12:59
  • 197
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:myeclipse10下 Java compiler level does not match解决方法
举报原因:
原因补充:

(最多只允许输入30个字)