HDU5410 CRB and His Birthday(混合背包)

题目:

CRB and His Birthday

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1893    Accepted Submission(s): 894


Problem Description
Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with  M  Won(currency unit).
At the shop, there are  N  kinds of presents.
It costs  Wi  Won to buy one present of  i -th kind. (So it costs  k  ×  Wi  Won to buy  k  of them.)
But as the counter of the shop is her friend, the counter will give  Ai × x + Bi  candies if she buys  x ( x >0) presents of  i -th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤  T  ≤ 20
1 ≤  M  ≤ 2000
1 ≤  N  ≤ 1000
0 ≤  Ai, Bi  ≤ 2000
1 ≤  Wi  ≤ 2000
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:
The first line contains two integers  M  and  N .
Then  N  lines follow,  i -th line contains three space separated integers  Wi Ai  and  Bi .
 

Output
For each test case, output the maximum candies she can gain.
 

Sample Input
  
  
1 100 2 10 2 1 20 1 1
 

Sample Output
  
  
21
Hint
CRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.
 

Author
KUT(DPRK)
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   6018  6017  6016  6015  6014 
 

Statistic |  Submit |  Discuss |  Note
思路:

你有M块钱,现在有N件商品
第i件商品要Wi块,如果你购买x个这样的商品,你将得到Ai*x+Bi个糖果
问能得到的最多的糖果数
 

首先,对于第i件商品,如果只买1个,得到的价值是Ai+Bi
如果在买1个的基础上再买,得到的价值就是Ai
也就是说,除了第一次是Ai+Bi,以后购买都是Ai
那么,我们能否将i商品拆分成两种商品,其中两种商品的代价都是Wi,
第一种的价值是Ai+Bi,但是只允许买一次
第二种的价值是Ai,可以无限次购买

所以这道题的思路就是先进行01背包,然后在进行完全背包

代码:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <string>
#include <iostream>
#include <stack>
#include <map>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define N (2000+20)
#define M 200010
#define MOD (1000000000+7)
#define inf 0x3f3f3f3f
#define LL long long
using namespace std;
int m,n,dp[N];
struct node
{
    int w,a,b;
} zz[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        mem(dp,0);
        scanf("%d%d",&m,&n);
        for(int i=0; i<n; i++)
            scanf("%d%d%d",&zz[i].w,&zz[i].a,&zz[i].b);
        for(int i=0; i<n; i++)
        {
            for(int j=m; j>=zz[i].w; j--)//01背包
                dp[j]=max(dp[j],dp[j-zz[i].w]+zz[i].a+zz[i].b);
            for(int j=zz[i].w; j<=m; j++)//完全背包
                dp[j]=max(dp[j],dp[j-zz[i].w]+zz[i].a);
        }
        int sum=-1;
        for(int i=0; i<=m; i++)
            sum=max(sum,dp[i]);//找出最大值
        printf("%d\n",sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值