POJ 3468 A Simple Problem with Integers

Description
You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15

Hint
The sums may exceed the range of 32-bit integers.

一道线段树的模板题,题目大意:建立一棵线段树,支持区间加法,区间求和。

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=100000;
struct node
{
    int l,r;
    long long sum,tmp;
}tree[4*maxn+1];
int n,q,data[maxn+1];
void build(int l,int r,int num)
{
    tree[num].l=l;
    tree[num].r=r;
    if(l==r)
    {
        tree[num].sum=data[l];
        return ;
    }
    int mid=(l+r)/2;
    build(l,mid,2*num);
    build(mid+1,r,2*num+1);
    tree[num].sum=tree[2*num].sum+tree[2*num+1].sum;
}
void update(int num)
{
    tree[2*num].tmp+=tree[num].tmp;
    tree[2*num].sum+=tree[num].tmp*(tree[2*num].r-tree[2*num].l+1);
    tree[2*num+1].tmp+=tree[num].tmp;
    tree[2*num+1].sum+=tree[num].tmp*(tree[2*num+1].r-tree[2*num+1].l+1);
    tree[num].tmp=0;
}
void add(int l,int r,int x,int num)
{
    if(tree[num].l>r||tree[num].r<l)
        return ;
    if(tree[num].l>=l&&tree[num].r<=r)
    {
        tree[num].tmp+=x;
        tree[num].sum+=x*(tree[num].r-tree[num].l+1);
        return ;
    }
    if(tree[num].tmp)
        update(num);
    add(l,r,x,2*num);
    add(l,r,x,2*num+1);
    tree[num].sum=tree[2*num].sum+tree[2*num+1].sum;
}
long long find_sum(int l,int r,int num)
{
    if(tree[num].l>r||tree[num].r<l)
        return 0;
    if(tree[num].l>=l&&tree[num].r<=r)
        return tree[num].sum;
    if(tree[num].tmp)
        update(num);
    return find_sum(l,r,2*num)+find_sum(l,r,2*num+1);
}
int main()
{
    char ch;
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;++i)
        scanf("%d",data+i);
    build(1,n,1);
    for(int i=1;i<=q;i++)
    {
        int a,b,c;
        cin>>ch;
        if(ch=='C')
        {
            scanf("%d%d%d",&a,&b,&c);
            add(a,b,c,1);
        }
        else
        {
            scanf("%d%d",&a,&b);
            printf("%lld\n",find_sum(a,b,1));
        }
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值