高级交换命令汇总

原创 2007年09月27日 12:03:00

用来显示debug的详细时间
service timestamps debug datetime msec
加log的时间戳
service timestamps log datetime msec

show debugging
show logging
clear logging

创建vlan
vlan 30
name wg30

show vlan
show vlan brief


共4096个vlan
0,4095保留
1 常规
2---1001常用
1002---1005 其他用途
1025---4094 常用 透明模式用,一般用于语音

show version
show cdp neighbors
clear cdp table

access口接pc机,svi口虚拟口vlan的口,三层接口当路由器口用

将接口划分到vlan
switchport mode access
no switchport ; 将接口改为三层接口
switchport ;将接口改为二层接口

switchport access vlan 30

进入多个接口
interface range f0/2 - 6
interface range f0/7 , f0/11 , f0/14
interface range f0/15 , f0/17 - 20

查看trunk
show interface trunk

n-802.1q  ;n--自动协商

配置trunk
switchport mode trunk
switchport trunk enc  dot1q    ;封装dot1q   
switchport trunk enc  isl  ;封装isl
switchport trunk enc negotitle ;自动协商

分配trunk所承载的valn
在trunk口下
switchport trunk allowed vlan 4,5,6,7
switchport trunk allowed vlan add 8
switchport trunk allowed vlan add 9

trunk状态
on-----trunk
off----access
negotitle---非协商和on连用
desivble---主动协商
auto---接受协商
switchport mode access
switchport mode trunk
switchport mode dynamic desivble
switchport mode dynamic auto

show interface f0/23 sw
show interface f0/23 trunk

vtp mode server
vtp mode tran
vtp mode client
vtp domain cisco
vtp password cisco

show vtp s
show vtp count
show vtp password

vtp ver 1 2 ;1 2 版本切换
vtp pruning ;启用vtp修剪

show flash ;查看flash
delete flash:/vlan.dat ;删除vlan信息

int vlan 10    ;多层交换中的vlan互访
ip add 10.10.10.10 255.255.255.0
int vlan 20
ip add 20.20.20.20 255.255.255.0
ip routing
sh ip route    

stp
过程:
one root bridge per network
one root port per nonroot bridge
one designated port per segment
nondesignated ports are blocked

lowest root BID
lowest path cost to root bridge
lowest sender BID
lowest port ID (sender)

cisco设备默认pvst

show spanning-tree
show span vlan10

span vlan 10   ;启用vlan10的生成树协议
no span vlan 10  ;禁用vlan10生成树协议

sh span inter f0/23  ;查看f0/23下的vlan stp
sh span int f0/23 de  ;查看f0/23下的优先级,ID等
sh span vlan 10 root    ;查看vlan10的根

配置根桥
span vlan 10 prio 4096 的倍数  ;修改BID的优先级
span vlan 10 port 16 的倍数 ;修改接口的优先级,接口下
span vlan 10 cost 3  ;修改cost值,接口下

sh span brige   ;查看桥ID
sh span root   ;查看根ID
sh span de
sh span vlan 10 sum  ;查看stp特性

int range f0/1 - 24  
span portfast   ;将接口改为portfast

show span uplinkfast  ;uplinkfast不能单独使用,会该vlan优先级,直链失效的交换机配置,backbonfast,非直链线路失效

rootguard,根守护,后来的交换机不能代替根
span guard root  ;接口下打,根的所有接口
span uplinkfast  ;全局模式下,所有交换机上配置,核心上配置
span backbonefast ;全局模式下,所有交换机上配置

EC--捆绑
2,4,6,8
PAGP---CISCO私有
LACP---公有
chanel-group 1 mode on ;启用捆绑,在所有需要的接口下,2,4,6,8
int port-chanel 1
no swichthport ;需在单个接口下打开,例 int f0/1 ,no sw
sw access trunk
  
chanel-group 1 mode active ;LACP
chanel-group 1 mode auto ;PAGP
chanel-group 1 mode desirable ;PAGP
chanel-group 1 mode on  ;Ethernet
chanel-group 1 mode passive ;LACP

sh ip int br
sh int port-chanel 1

负载均衡方式:
port-chanel load-balance dst ;基于目的ip
port-chanel load-balance src    ;基于源ip

chanel-proto lacp  ;封装的协议,在接口下
chanel-proto pagp ;封装的协议,在接口下

HSRP OR VRRP 热备份
HSRP
standby 1 ip 192.168.1.1 ;设置虚拟ip,都是接口下命令,接口ip为 192.168.1.2和192.168.1.3
standby 1 priority 110  ;设置优先级,默认为100
standby 1 preempt  ;设置抢回,可选延迟
standby 1 track f0/21    ;设置监视接口,此为监视f0/21接口,如果接口出故障,优先级会适当降低

show standby
show standby br   ;state change 为切换次数

int vlan 100
ip add 100.100.100.100 255.255.255.0
standby 1 ip 100.100.100.1
standby 1 priority 110
standby 1 preempt

VRRP

vrrp 1 ip 192.168.1.1
vrrp 1 priority 110
vrrp 1 preemt   ;VRRP是公共标准,在cisco设备中只有6500支持

端口安全
sh log
switchport mode access     ;命令在接口下,接口必须为access模式
switchport port-sec     ;启用端口安全
switchport port-sec max 20    ;允许最大mac地址数
switchport port-sec mac-add [stichy]   ;添加mac地址,stichy为粘贴
switchport port-sec violation [prot] [res] [shut] ;违反所做动作 prot---丢弃,res---丢弃并记入log,shut---关闭端口
show port-security     ;验证端口安全

802.1x 认证:
aaa new-model    ;启用aaa,在全局模式下
aaa authen dot1x defau [list]  ;创建方式列表
dot1x system-auth-control  ;启用802.1x端口认证

dot1x port-control auto   ;在所需认证的端口下,启用认证

username cisco password cisco

 

SPAN 端口镜像----将某一端口的所有数据帧都复制一份到指定端口

monitor session 1 sour int f0/7  ;全局下,源端口
monitor session 1 dest int f0/5  ;目的端口
no monitor session 1   ;去除span

RSPAN---远程span

A:
inter vlan 20
remote-span
monitor session 1 soure int f0/16 both
monitor session 1 destin remot vlan 20

B:
int vlan 20
remote-span

C:
int vlan 20
remote-span
monitor session 1 source remote vlan 20
monitor session 1 dest inter f0/1  ;vlan 20 为专用vlan

sh remote-vlan    ;rspan的查看命令

VACL---基于vlan的acl

vlan access-map test2 10  ;全局模式下建立vacl,名字test2,序号为10
match ip/mac address [acl号]  ;匹配的ip或mac地址,或为acl
action forward/drop    ;匹配后的动作
      
vlan fiter test2 vlan-list 20  ;全局模式下应用vacl,test2为vacl名,20为vlan号


SSH

hostname r1
ip domain-name wg0604.com
crypto key generate rsa   ;全局模式下,建立SSH的三个前提

line vty 0 4
transport input ssh/telnet
login local    ;设立ssh,login local应用uername cisco   password cisco

sh ssh
sh ip ssh     ;ssh查看命令

ssh timeout 30    
ssh authen 5    ;无法应用,超时和最大认证次数,全局下


组播

PIM-DM

ip multicast-routing ; 全局下启用组播
ip pim dense-mode/sparse-mode/sparse-dense-mode ;PIM模式,在所应用的接口上

PIM-SM

ip multicast-routing  ;全局下启用组播
ip pim sparse-mode  ;应用的接口下启用SM
ip pim rp-address 环回口 ;全局下手工指定rp,指其loopback口地址

ip pim bsr-candidate int 环回口    ;指定cbsr,指其环回口
ip pim rp-candidate 地址 group 组播访问列表  ;指定crp,及其所管理的组播范围
ip pim send-rp-disc scope 阀值(泛洪边界,即TTL值) ;限定rp发送消息的边界
ip pim version 1/2      ;设定版本,默认为2
ip pim bsr-border      ;设定bsr边界


sh ip mroute
sh ip pim interface   ;组播查看命令 

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

RAR 高级命令linux/unix

rar 用法: rar - ....-     通常rar命令由一个主命令加若干选项(可选)构成,操作文档为操作施加的.rar文件对象, 文件或文件列表为对操作文档实现修饰的具体文件或目...

英文seo用google高级搜索命令寻找高质量外链

site: 当我们用site提交查询的时候,Google会限制查询仅在某个网站,或是某个域下面进行。例[admissions site:www.lse.ac.uk],提交这个查询仅仅会搜索网站www....
  • lgq023
  • lgq023
  • 2011-03-19 15:05
  • 1582

对 Linux 初级、中级、高级用户非常有用的 60 个命令(转)

对 Linux 初级、中级、高级用户非常有用的 60 个命令     初级篇:   你打算从Windows换到Linux上来,还是你刚好换到Linux上来?哎哟!!!我说...

confluence创建文件报错 can not create to file /tmp/xxx Errcode:28,引出的 df命令高级用法

使用confluence创建文件时,报错如下: Can't create/write to file '/tmp/#sql_118c_0.MYI' (Errcode: 28); nested exc...

linux特殊权限和高级命令----宋轶聪

特殊权限前面我们学习过linux的基本权限,但如果只有基本权限,可能无法满足各式各样的要求 例如:建立一个公共目录 任何人都可以在目录里建立自己的文件,但只能删除自己的文件,此时基本权限就无能为力了....
  • etune
  • etune
  • 2011-01-12 17:04
  • 819

命令行高级快捷键

1、鼠标移动命令 组合键 动作 CTRL+A 光标移动到行首 CTRL+E 光标移动到行末 CTRL+F 光标向前移动一个字符;跟“→”一样 CTRL+B 光标向后移动一个字符;...

Linux中tar命令高级用法——备份…

Linux上有功能强大的tar命令,tar最初是为了制作磁带备份(tape archive)而设计的,它的作用是把文件和目录备份到磁带中,然后从磁带中提取或恢复文件。现在我们可以使用tar来备份数据到...

高级Bash脚本编程指南(25):文本处理命令(一)

高级Bash脚本编程指南(25):文本处理命令(一) 成于坚持,败于止步 处理文本和文本文件的命令 sort 文件排序, 通常用在管道中当过滤器来使用. 这个命令可以依据指定的关键字或指定的字...

你需要知道的12个Git高级命令

本文来源于我在InfoQ中文站翻译的文章,原文地址是:http://www.infoq.com/cn/news/2016/01/12-git-advanced-commands众所周知,Git目前已经...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)