HDU-1050 Moving Tables (贪心)

2 篇文章 0 订阅

题目:

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
这里写图片描述
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
这里写图片描述
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

Sample Output

10
20
30


思路:

  • 把每次移动的区间按left进行升序排序,然后依次比较是否可以合并在一个时间搬运,可以的话计数器就+1,计数器等于总搬运次数就停止循环。
  • 代码不难写,主要刚开始小错误太多,看别人给的数据调了1个小时才调好。

This is Code:

#include<bits/stdc++.h>
using namespace std;

typedef struct{
    int l, r;
}node;

node ta[300];
bool vis[300];

bool cmp(node a, node b){
    return a.l < b.l;
}

bool judge(int a, int b){
    if (a % 2) ++a;
    if (b > a) return true;
    else return false;
}

int main()
{
    int kase, n;
    scanf("%d", &kase);
    while(kase--){
        memset(ta, 0, sizeof(ta));
        memset(vis, 0, sizeof(vis));
        scanf("%d", &n);
        int a, b;
        for (int i = 0; i < n; ++i){
            scanf("%d%d", &a, &b);
            ta[i].l = min(a, b);
            ta[i].r = max(a, b);
        }
        sort(ta, ta+n, cmp);
        int cnt = 0, tempnum = 0, ans = 0;
        node temp = ta[0];
        while(cnt < n){
            for (int i = 1; i < n; ++i)
                if (!vis[i])
                    if(judge(temp.r, ta[i].l)){
                        temp = ta[i];
                        vis[tempnum] = true;
                        tempnum = i;
                        ++cnt;
                    }
            vis[tempnum] = true;
            ++ans;
            ++cnt;
            for (int i = 0; i < n; ++i){
                if (!vis[i]){
                    temp = ta[i];
                    tempnum = i;
                    break;
                }
            }
        }
        printf("%d\n", ans*10);
    }

    return 0;
}

其实这题还有更好的方法(虽然以上也是0MS过):
方法就是求最大重叠区间数量。

我一开始想不明白,后来反过来想,如果不重叠便可以合并,因此
最大重叠区间段就是所有可合并集合都重叠也就是需要一个个来的一段。
因此包含这一段的数量就是需要的十分钟数。

以下是这种方法的代码:

#include<bits/stdc++.h>
using namespace std;

int cnt[200];

bool cmp(int a,int b)
{
    return a > b;
}

int main()
{
    int T, n;
    scanf("%d", &T);
    while(T--)
    {
        memset(cnt, 0, sizeof(cnt));
        scanf("%d",&n);
        int a, b, l, r;
        for(int i = 0; i < n; ++i)
        {
            scanf("%d%d",&a,&b);
            l = min(a, b);
            r = max(a, b);
            //将两个对面的房间优化成一个点
            l = (l+1) / 2;
            r =( r+1) / 2;
            for(int j = l; j <= r; ++j)
                ++cnt[j];
        }
        sort(cnt, cnt+200, cmp);
        printf("%d\n", cnt[0]*10);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值