xmu:1007.A*B Big Number

1007.A*B Big Number
Time Limit: 3000 MS          Memory Limit: 65536 K 
Total Submissions: 3792 (997 users)          Accepted: 1165 (801 users) 
[ My Solution ]

Description

Calculate a*b

Input

Two integer a,b (0<=a,b<=101000)

Output

Output a * b

Sample Input

5 7

Sample Output

35

Source
xmu

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
/*
1,将输入转化为char数组;
2,char数组转为整型数组;
3,整型数组着位相乘。
*/

//将字符串数组转为整型数组
int* char2Int(char* a)
{
	//printf("%s",a);
	int aLen=strlen(a);
	int* ret;
	ret=(int*)malloc(sizeof(int)*1024);
	memset(ret,0,1024);
	int retIndex=0;
	for(int aIndex=aLen;aIndex!=0;aIndex--)
	{
		ret[retIndex++]=a[aIndex-1]-'0';
		//printf("%d",ret[retIndex-1]);
	}
	return ret;
}
int main()
{
	char a[1024],b[1024];
	int ret[2048]={0};
	scanf("%s %s",a,b);
	int aLen = strlen(a);
	int bLen = strlen(b);
	//0 判断
	if( (aLen==1&&a[0]=='0') || (bLen==1&&b[0]=='0') )
	{
		printf("0");
		return 0;
	}
	int retSize = aLen+bLen-2;
	int* aInt;
	int* bInt;
	aInt = char2Int(a);
	bInt = char2Int(b);
	int e=0;
	//将两数组着位相乘.
	for(int i=0;i<aLen;i++)
	{
		e=0;
		for(int j=0;j<bLen;j++)
		{
			int temp = ret[i+j]+aInt[i]*bInt[j]+e;
			ret[i+j] = temp%10;
			e = temp/10;
		}
		if(e!=0)
		{
			ret[i+bLen]=e;
		}
	}
	//最后进位处理.
	if(e!=0)
	{
		retSize++;
		ret[retSize]=e;
	}
	for(int i=retSize;i>=0;i--)
	{
		printf("%d",ret[i]);
	}
		
	free(aInt);
	free(bInt);
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值