1138. Postorder Traversal (25) 二叉树前序中须转后序

1138. Postorder Traversal (25)

时间限制
600 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:
7
1 2 3 4 5 6 7
2 3 1 5 4 7 6
Sample Output:
3

思路:万万没想到会考这么基础的题。。。给出二叉树的前序序列和中序序列求后序序列的第一的节点,都是基本操作


#include<cstdio>
#include<vector>
using namespace std;

vector<int>pos;
int n,pre[50000],ino[50000];

void getpos(int ps,int pe,int is,int ie){
	if(ps>pe) return;
	if(ps==pe){
		pos.push_back(pre[pe]);
	}
	else{
		int i=is;
		while(i<ie&&ino[i]!=pre[ps]) i++;
		getpos(ps+1,ps+i-is,is,i-1);
		getpos(ps+i-is+1,pe,i+1,ie);
		pos.push_back(pre[ps]);
	}
}

int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&pre[i]);
	}
	for(int i=0;i<n;i++){
		scanf("%d",&ino[i]);
	}
	getpos(0,n-1,0,n-1);
	printf("%d",pos[0]);
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值