hdu1233-还是畅通工程(Kruskal)

还是畅通工程
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最小的公路总长度。
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
Sample Output
3
5

简单模板题

#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn=105;
int fa[maxn];
void init(){
  for(int i=0;i< maxn;i++)
    fa[i]=i;
}
int Find(int x){
  if(fa[x]== x) return fa[x];
  else  return fa[x]=Find(fa[x]);
}

void Union(int x,int y){
  int fx=Find(x),fy=Find(y);
  if( fx!= fy)
    fa[fx] =fy;
}
typedef struct{
    int st,ed,cost;
}Edge;
Edge  edge[10005];
int cmp(Edge a,Edge b){
  return a.cost < b.cost;
}

int main(){
  ios_base::sync_with_stdio(false);
  int n;
  while(cin>>n,n){
    int t1,t2,t3;
    int m=n*(n-1)/2;
    for(int i=0;i<m;i++){
      cin>>t1>>t2>>t3;
      edge[i].st= t1;
      edge[i].ed= t2;
      edge[i].cost =t3;
    }
    init();
    sort(edge,edge+m,cmp);
    int rst=n;
    int tot_cost =0;
    for(int i=0; i<m && rst >1 ;i++){
      if(Find(edge[i].st) != Find(edge[i].ed)){
        Union(edge[i].st,edge[i].ed);
        rst--;
        tot_cost +=edge[i].cost;
      }
    }
    cout<<tot_cost<<endl;

  }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值