POJ2253-Frogger(Dijkstra变式)

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40814 Accepted: 13096
Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

分析
这里的Frog Distance 是指从起点到终点所有通路中最短的一条边.(每条通路的最短边中最短的边 即通路最短边的最短边)

#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
const int maxn=205;
#define INF 0x3f3f3f3f
int X[maxn];
int Y[maxn];
double g[maxn][maxn];
double dist[maxn];
int vis[maxn];
int last[maxn];
int fin_cnt;

void init(int n){
  memset(vis,0,sizeof(vis));
  memset(last,-1,sizeof(last));
  dist[0]=0;
  vis[0]=1;
  fin_cnt=1;
  for(int i=1;i<n;i++){
    dist[i]=g[0][i];
    last[i]=0;
  }

}

void  dijkstra(int n){
  int MIN,MIN_IDX;
  while( fin_cnt < n){
    MIN=INF;
    for(int i=1;i<n; i++){
      if(vis[i] ) continue;
      if(dist[i] < MIN )
        MIN=dist[i],MIN_IDX=i;
    }
    if(MIN == INF) break;
    fin_cnt++;
    vis[MIN_IDX] =1;
    for(int i=1;i<n;i++){// Dijkstra变式
      double mx=max(dist[MIN_IDX],g[MIN_IDX][i]);// 为了形成一条路,必须取max
      dist[i]=min(dist[i],mx);//在所有能到达的路中选最短的一条边
    }
  }
}

int main(){
  // freopen("in.txt","r",stdin);
  ios_base::sync_with_stdio(false);
  int n;
  int cas=1;
  while(cin>>n,n){
    for(int i=0;i<n;i++)
      for(int j=0;j<n;j++)
        g[i][j]=(i==j? 0:-INF);

    for(int i=0 ;i <n;i++){
      cin>>X[i]>>Y[i];
    }

    for(int i=0;i<n;i++){
      for(int j=0;j<n;j++){
        if(i==j) continue;
        g[i][j]=sqrt( pow(X[i]-X[j],2)+pow(Y[i]-Y[j],2) );
      }
    }

    init(n);
    dijkstra(n);
    printf("Scenario #%d\n",cas++);
    printf("Frog Distance = %.3f\n\n",dist[1]);


  }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值