数据结构上机测试2-2:单链表操作B

这篇博客详细介绍了数据结构上机测试中关于单链表操作B的题目,包括题目描述、输入输出规范以及示例,帮助读者理解并解决此类问题。
摘要由CSDN通过智能技术生成

数据结构上机测试2-2:单链表操作B

题目描述

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

输入

第一行输入元素个数n;
第二行输入n个整数。

输出

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

示例输入

10
21 30 14 55 32 63 11 30 55 30

示例输出

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

#include<bits/stdc++.h>
using namespace std;
struct  node
{
    int data;
    struct node *next;
}*p,*q,*head,*tail;
void display(struct node *head);
int main()
{
    int i,n;
    cin>>n;
    head=new node;
    head->next=NULL;
    for(i=0; i<n; i++)
    {
        p=new node;
        cin>>p->data;
        p->next=head->next;
        head->next=p;
    }
    cout<<n<<endl;
    display(head);
    p=head->next;
    while(p)
    {
        q=p->next;
        tail=p;
        while(q)
        {
            if(q->data==p->data)
            {
                tail->next=q->next;
                q=tail->next;
                n--;
            }
            else
            {
                q=q->next;
                tail=tail->next;
            }
        }
        p=p->next;
    }
    cout<<n<<endl;
    display(head);
}
void display(struct node *head)
{
    p=head->next;
    while(p)
    {
        if(p->next)
        {
            cout<<p->data<<" ";
        }
        else
            cout<<p->data<<endl;
        p=p->next;
    }
}

//还有一种方法较为麻烦,但也可以用,和数组类似
#include<stdio.h>  
#include<stdlib.h>  
struct node  
{  
    int data,lit;  
    struct node *next;  
};  
int main()  
{  
    int n,i,t;  
    struct node *head,*p,*q;  
    scanf("%d", &n);  
    head=(struct node *)malloc(sizeof(struct node));  
    head->next=NULL;  
    for(i=1;i<=n;i++)  
    {  
        p=(struct node *)malloc(sizeof(struct node));  
        scanf("%d", &p->data);  
        p->lit=i;    //存入每一个元素的位置
        p->next=head->next;  
        head->next=p;  
    }  
    printf("%d\n", n);  
    for(p=head->next;p!=NULL;p=p->next)  
    {  
        if(p==head->next)  
        {  
            printf("%d", p->data);  
        }  
        else  
        {  
            printf(" %d", p->data);  
        }  
    }  
    printf("\n");  
    for(p=head->next;p!=NULL;p=p->next)  
    {  
        for(q=head->next;q->next!=NULL;q=q->next)     //进行选择排序
        {  
            if((q->data)>(q->next->data))  
            {  
                t=q->data;q->data=q->next->data;q->next->data=t;  
                t=q->lit;q->lit=q->next->lit;q->next->lit=t;  
            }  
        }  
    }  
    for(p=head->next;p->next!=NULL;)  
    {  
        if(p->data==p->next->data)      //筛选重复的元素
        {  
            q=p->next;  
            p->next=q->next;  
            free(q);  
            p=p;  
            n--;  
        }  
        else  
        {  
            p=p->next;  
        }  
    }  
        for(p=head->next;p!=NULL;p=p->next)  
    {  
        for(q=head->next;q->next!=NULL;q=q->next)      //按下标排列回原来的位置
        {  
            if((q->lit)<(q->next->lit))  
            {  
                t=q->data;q->data=q->next->data;q->next->data=t;  
                t=q->lit;q->lit=q->next->lit;q->next->lit=t;  
            }  
        }  
    }  
        printf("%d\n",n);  
    for(p=head->next;p!=NULL;p=p->next)      //输出
    {  
        if(p==head->next)  
        {  
            printf("%d", p->data);  
        }  
        else  
        {  
            printf(" %d", p->data);  
        }  
    }  
    printf("\n");  
    return 0;  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值