关闭

RIP学习笔记

432人阅读 评论(0) 收藏 举报

小型网络比较适用静态路由技术

大中型网络一般采用动态路由协议


RIP 路由信息协议

RIP基本特征应用层  UDP520端口  BGP


基于运行特征分类

距离矢量协议  RIP EIGRPBGP

链路状态协议  OSPF ISIS


基于运行范围

IGP(内部网关协议)

EGP(外部网关协议)BGP


基于有类,无类

有类  RIPv1 IGRP

无类


动态路由协议能够动态适应拓扑

快速实现网络收敛(故障-->恢复)


最长匹配<管理距离<度量值


最长匹配原则

定义:将通信目的IP和本地路由条目进行对比,从左到右,若匹配的比特位越多,则越优先精确


管理距离(优先级)

范围0-255

越小越优先


度量值 metric

当网络中有一种路由协议,用于执行路径选择

RIP 跳数hop 经过一个路由器叫一跳

EIGRP 混合度量值AD/FD

OSPF 开销cost  100M/带宽

ISIS 开销

BGP 选路原则


router rip

network 12.0.0.0 (用于宣告主类网络号,不需要具体的路由条目)

每30秒发送一次,

故障收敛(从动荡到稳定的时间 240s )


自动汇总:ripv1根据路由所在的类别,将网段的网络位保留,主机位归零,得到的最终网段,此网段称为有类网段


RIP路由分组

Request触发式

用于刚启动进程时,对邻居进行请求


Response也称为route update

功能:用于承载和传递路由条目

周期更新25.5-30

广播更新255.255.255.255

不可靠更新


RIP计时器

周期更新计时器 30

失效计时器 180  没有更新就失效  与抑制计时器没联系

抑制计时器 180  

当收到故障路由之后,默认会直接删除本故障路由,若此时从远方又收到此路由,则有可能造成再次环路

当收到故障路由时候,保持180s之后再删除路由条目

刷新计时器 240


修改计时器   timers basic  5 30 30 40     更新计时器   失效计时器   抑制计时器  刷新计时器


RIPv2

加命令

no auto-summary

version 2

发往224.0.0.9  组播发送

无类路由协议

夹带子网掩码信息

增量更新+周期更新


路由算法

路由算法可以根据路径参数(度量值)生成路由条目

本地无则录入

本地有,新的优,录入

本地有,新的差,但是从原路由发送的,录入

贝尔曼算法

 

路由防环

浪费网络带宽

耗散系统资源

 

水平分割

从本接口收到的路由条目,不能再从本接口发送出去

最大16跳

跳数达到16跳,此路由失效并且被丢弃(最大有效15跳)

路由中毒

路由条目发生故障,将此路由标记为16跳,发送给邻居

毒性逆转

邻居会返回16跳中毒路由实现确认

抑制计时器180s


路由汇总

可以将路由表进行表项压缩减少路由表体积

可以提高路由器的转发效率


子网汇总的原理:从左到右找到相同比特位,相同的比特位个数即为最终汇总码,其他不同比特位归结为0


secondary 从地址,辅助地址

必须先写主地址,从地址才生效


路由汇总的部署

汇总路由的路由掩码必须大于或等于主类掩码   在f0/0和f1/0进行部署

ip summary-address rip  192.168.0.0 255.255.252.0. 会报错



路由认证

编写钥匙串,定义密钥

key clain rip   定义钥匙串

key 1               定义密钥序号

key-string cisco   定义密钥


show run | s k c

show key clain

借口下调用密钥

interface f0/0

ip rip authentication mode md5     定义认证类型

ip rip authentication key-clain rip        调用密钥串

注意:密钥串名字可以不一样,但是密钥序号和密钥需要一致


要相同的路由格式(RIPv2)


动态默认路由

CS核心交换机 core switch

DS汇聚交换机 distribution swiitch

AS接入层交换机


配置方便,动态适应网络拓扑

router rip

default-information originate


RIP被动接口

定义:流量优化请求

只收不发(passive-interface)

用在互联网出口

内网的二三层交换机


router rip

passive-interface f0/0  路由器执行

passive-interface vlan 10/20/30一般在汇聚层交换机上进行


passive-interface default 将所有接口设置为被动接口

no passive interface f0/0 开启某个接口

之后路由表不会更新而丢弃


RIP单播更新

router rip

neighbor 12.1.1.2 单播指定邻居,采用单播包与邻居交互

passive-interface default 被动接口特性只能抑制组播,广播报,无法抑制单播包


RIP流量优化=被动接口+单播更新


RIP偏移列表

用于修改其度量值(跳数)

offset-list(只增不减)

通过ACL匹配路由

access-list 1 permit 2.2.2.2

通过偏移列表调用ACL

router rip

offset-list 1 in 5 f0/0  从接口f0/0近来的路由增加跳数5


offset-list 1 out 12 f0/0  从接口f0/0出去的路由增加跳数12


offset-list 0 out 12 f0/0 从接口f0/0所有的路由增加12


备用路由不会显示,需要关闭更优的路由才会看到

0
0
查看评论

RIP路由协议及工作原理

下面内容摘自笔者编著的《网管员必读——网络基础》(第2版)一书。9.11.1 RIP路由协议及工作原理RIP(Routing information Protocol,路由信息协议)是应用较早、使用较普遍的内部网关协议(Interior Gateway Protocol,IGP),适用于小型同类网络...
  • lycb_gz
  • lycb_gz
  • 2007-05-16 21:43
  • 41113

RIP个人理解

前言本身研究RIP的意义不大,因为现在基本不用RIP,但是理解RIP之后,对理解OSPF,BGP有很大的帮助概述Routing information Protocol,路由信息协议,是第一代动态路由协议;所属距离矢量协议,基于跳数来进行路径选择(最多支持15跳)。RIP协议有多个版本,分为v1/v...
  • treepapap
  • treepapap
  • 2016-10-22 21:57
  • 820

谈谈RIP协议中的计时器

说明:本文仅供学习交流,转载请标明出处,欢迎转载! 本文是如下wen
  • JXH_123
  • JXH_123
  • 2014-04-28 10:38
  • 1154

RIP(三)【报文控制】

Output 命令rip output用于配置允许一个接口发送RIP更新消息。如果想要禁止指定接口发送RIP更新消息,可以在接口上运行命令undo rip output。缺省情况下,ARG3系列路由器允许接口发送RIP报文。 企业网络中,可以通过运行命令undo rip output来防止连接外...
  • LAINCLAK
  • LAINCLAK
  • 2017-08-17 19:40
  • 481

动态路由协议的基本配置---RIP

动态路由协议的基本配置---RIP 在上一篇博客中我们讲解了如何配置静态路由与缺省路由,这次,我们学习一下动态路由协议体系中的RIP协议。 RIP协议英文名称为Routing Information Protocol ,中文名称为路由信息协议。RIP是一种基于距离矢量算法的路由协议,它基于UDP传输...
  • valecalida
  • valecalida
  • 2016-12-14 21:44
  • 2010

路由选择协议OSPF 与RIP的比较

RIP是一种分布式的基于距离向量的路由选择协议, OSPF是一种分布式的基于链路状态的路由选择协议 RIP:仅于相邻的路由器交换状态;路由器交换的信息是当前本路由器所知道的全部信息,即路由表;按固定的时间间隔交换路由信息 OSPF:向本自治系统所有的路由器发送信息;发送的信息是与本路由...
  • IYC_Q
  • IYC_Q
  • 2016-06-27 21:10
  • 5311

路由信息协议(RIP)的防环机制

防环机制 1-记数最大值(maximum hop count):定义最大跳数(最大为15跳),当跳数为16跳时,目标为不可达。 2-水平分割(split horizon):从一个接口学习到的路由不会再广播回该接口。cisco可以对每个接口关闭水平分割功能。 3-路由毒化(rou...
  • stardsd
  • stardsd
  • 2016-03-15 23:38
  • 1587

路由选择RIP协议解析

RIP协议解析 关于理想路由选择协议的特点: 正确性和完整性:沿路由表所指引的路由一定能达到目的网络和目的主机算法简单:不应使网络通信量增加太多额外开销适应通信量和网络拓扑的变化:自适应的改变路由均衡各链路的负载,发生故障或者修理好重运营时能及时的改变路由稳定性:在通信量和网络拓...
  • qq_33452263
  • qq_33452263
  • 2016-08-04 01:51
  • 3678

RIP设置

RIP的功能: 1、 支持用于防止路由环路的水平分割和带毒性反转的水平分割 2、 能够在多达十六条的等价路径上进行负载均衡。默认为4条。 3、 易于配置 4、 能够工作在多种路由器品牌共存的复杂环境中被动接口:特定的路由协议的更新就不会从这个接口发送出去 Router(config...
  • liao152
  • liao152
  • 2015-06-04 20:04
  • 232

RIP协议的配置

拓扑图: 要求: 理解RIP协议的工作原理,并通过 RIP 路由协议实现不同网络互通。 配置步骤:  1、配置好 PC 机的 IP 地址等参数。 PC 0>ipconfig IP Address......................:...
  • bluedream1219
  • bluedream1219
  • 2015-07-16 17:25
  • 630
    个人资料
    • 访问:45029次
    • 积分:919
    • 等级:
    • 排名:千里之外
    • 原创:46篇
    • 转载:16篇
    • 译文:1篇
    • 评论:1条
    最新评论