POJ1065——Wooden Sticks(动态规划,二分优化)

原题如下:

Wooden Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21590 Accepted: 9197

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

思路:遇到过好几个这样的题目了。就是把序列分为x个不下降子序列,求x的最小值。

一个定理是x就等于最长下降子序列的长度。不会证明QAQ。

直接dp就好。

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;

#define MAXN 5010
#define INF 1e9+7
#define MODE 1000000
#define LIMIT 100000000000000000
typedef long long ll;


int t,n;
struct woo{
    int l;
    int w;
}a[MAXN];

int cmp(woo a,woo b)
{
    if(a.l!=b.l)
        return a.l<b.l;
    else
        return a.w<b.w;
}
int dp[MAXN];//最长上升子序列的计算

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d%d",&a[i].l,&a[i].w);
        }
        sort(a,a+n,cmp);
        int maxn=-1;
        for(int i=0;i<n;i++){
            dp[i]=1;
            for(int j=0;j<i;j++)
            {
                if(a[j].w>a[i].w)
                    dp[i]=max(dp[i],dp[j]+1);
            }
            maxn=max(maxn,dp[i]);
        }
        printf("%d\n",maxn);
    }
}






但这样不是最快的。因为求最长上升子序列和最长下降子序列的时候,最多有效更新只有一次。

用二分找到需要更新的位置即可、

代码如下。

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;

#define MAXN 5010
#define INF 1e9+7
#define MODE 1000000
#define LIMIT 100000000000000000
typedef long long ll;


int t,n;
struct woo{
    int l;
    int w;
}a[MAXN];

int cmp(woo a,woo b)
{
    if(a.l!=b.l)
        return a.l>b.l;
    else
        return a.w>b.w;
}
int dp[MAXN];//最长上升子序列的计算

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d%d",&a[i].l,&a[i].w);
        }
        sort(a,a+n,cmp);
        fill(dp,dp+n,INF);
        for(int i=0;i<n;i++)
        {
            *lower_bound(dp,dp+n,a[i].w)=a[i].w;
        }
        printf("%d\n",lower_bound(dp,dp+n,INF)-dp);
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值