POJ3268————Silver Cow Party(最短路)

22 篇文章 0 订阅

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19688 Accepted: 9008

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.


裸的最短路

熟悉一下

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;
const int MAXN=1010;
const int MAXM=100010;
const int INF=1000000007;
int tot=0;
int head[MAXN];
struct edge{
	int v,w,next;
};
edge e[MAXM];
void add(int u,int v,int w){e[tot].v=v;e[tot].w=w;e[tot].next=head[u];head[u]=tot++;}
int d[MAXN][MAXN];
typedef pair <int,int>    P;  
void dij(int s){  
    priority_queue<P,vector<P>,greater<P> > que;  
    fill(d[s],d[s]+MAXN,INF);  
    d[s][s]=0;  
    que.push(P(0,s));  
    while(!que.empty()){  
        P p=que.top();  
        que.pop();  
        int u=p.second;  
        if(d[s][u]<p.first)  
            continue;  
        for(int k=head[u];k!=-1;k=e[k].next){  
            int v=e[k].v;  
            int w=e[k].w;   
            if(d[s][v]>d[s][u]+w){  
                d[s][v]=d[s][u]+w;  
                que.push(P(d[s][v],v));  
            }  
        }  
    }  
}  
int main()
{
	int n,m,x;
	scanf("%d%d%d",&n,&m,&x);
	tot=0;
	memset(head,-1,sizeof(head));
	for(int i=0;i<m;i++){
		int u,v,w;
		scanf("%d%d%d",&u,&v,&w);
		add(u,v,w);
	}
	for(int i=1;i<=n;i++){
		dij(i);
	}
	int MAX=0;
	for(int i=1;i<=n;i++){
		MAX=max(MAX,d[i][x]+d[x][i]);
	}
	printf("%d\n",MAX);
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值