关闭

wampserver 上 phalcon安装 配置

852人阅读 评论(2) 收藏 举报
分类:

先放上参考的:

我的环境是64位的 Win7,Wampserver2.4 集成包(Apache 2.4.4,php5.4.12,MySQL 5.0.10)。 

安装 Phalcon 也极其简单,只需要下载一个文件(php_phalcon.dll),

要以 phpinfo() 里面“Architecture”属性为准!

下载地址是 http://phalconphp.com/download。把php_phalcon.dll 解压出来放在 {WampServer安装目录}\bin\php\php5.4\ext 目录下面, 

然后修改php.ini文件

PHP.ini配置文件增加参数“extension=php_phalcon.dll”, 

然后重启 Apache 服务就好了,

重启后用phpinfo查看是否安装成功。 

如果服务器报 500 internal server error, 

一般就是 Phalcon 版本和环境不统一。

比如“Phalcon 1.1.0 - Windows x86 for PHP 5.4.0 NTS (VC9)”, 

就是给32位系统(x86)用的,对应的PHP版本是5.4.0(只要是5.4就可以,比如5.4.1也行)。

NTS是非线性安全的,如果你的phpinfo()显示“Thread Safety”是“enable”的状态, 

那么你需要下载不带“NTS”这个标志的。“VC9”是用来标记编译器的,现在只有 VC9 的可以下载。

当然也可以根据 phpinfo() 里面的“Compiler”属性去判断。 

安装 Phalcon 时,不能以操作系统是多少位的来判断下载哪个安装包,

而是要以 phpinfo() 里面“Architecture”属性为准! 

因为Phalcon 是作为PHP的扩展存在的,当然要以PHP是多少位的为准!


但是这样做完以后并没有什么用,但是也没有报任何错,原因是不止要在php下的php.ini配置extension=php_phalcon.dll 还要在apache下的 php.ini配置extension=php_phalcon.dll  php下的phpForApache.ini我也配置了这句话

这样配置后就可以用了 

另外注意版本问题


2
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:38942次
    • 积分:1087
    • 等级:
    • 排名:千里之外
    • 原创:75篇
    • 转载:16篇
    • 译文:0篇
    • 评论:3条
    文章分类
    最新评论