PAT_A 1004. Counting Leaves (30)

1004. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.
Sample Input

2 1
01 1 02

Sample Output

0 1

  • 题目分析

    • 考察内容:树,这是我做过pat_a 30分里最简单的一道,而且一次通过。
    • 题目内容:计算树的每层没有孩子的结点个数,并且树根的ID是01。
  • code

#include<iostream>
#include<vector>
using namespace std;
struct _T
{
    int d;//深度
    vector<int>c;//孩子
};
_T tree[100];
vector<int> td;//记录每层没有孩子结点的个数
int _max=-1;//记录这个树的总层数
//利用dfs方式更新每个结点的深度
void upDeep(_T& t,int d)
{
    if(t.c.size()==0)
    {
        t.d=d;
        if(d>_max)//计算总层数
          _max=d;
        return;
    }
    for(int i=0;i<t.c.size();i++)
      upDeep(tree[t.c[i]],d+1);
}
void dfs(_T &t)
{
    if(t.c.size()==0)
    {
        //统计每层没有孩子的结点的个数
        td[t.d]++;
        return ;
    }
    for(int i=0;i<t.c.size();i++)
    {
      dfs(tree[t.c[i]]);
    }
}
int main()
{
    int N,M,ID,K,CH;
    cin>>N>>M;
    for(int i=0;i<M;i++)
    {
        cin>>ID>>K;
        for(int j=0;j<K;j++)
        {
            cin>>CH;
            tree[ID].c.push_back(CH);
        }
    }
    upDeep(tree[1],1);
    //树根在第一层,td[0]不用
    td.assign(_max+1,0);
    dfs(tree[1]);
    for(int i=1;i<td.size();i++)
    {
        if(i==td.size()-1)
          cout<<td[i]<<endl;
        else
          cout<<td[i]<<" ";
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值