PAT_A 1040. Longest Symmetric String (25)

PAT_A 1040. Longest Symmetric String (25)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11
  • 分析:
    寻找最大对称子串,方法:1.确定对称中心 2.从中心开始向外扩展,计算长度 3.在所有对称子串中选择长度最大的。
  • code:
#include<iostream>
#include<cstdio>
using namespace std;
int longestStr(string &str,int i,int j,int size)
{
    while(i>=0&&j<size&&str[i]==str[j])
    {
        i--;
        j++;
    }
    return j-i+1-2;
}
int main()
{
    freopen("in","r",stdin);
    string str;
    getline(cin,str);
    int longest=0;
    int tmp=1;//这就有点坑,该字符串symmetric string length>=1
    int tmp1=1;//如 A:1 AB:1 AA:2 BAAAB:5
    int strSize=str.length();
    //定点-扩展
    for(int i=0;i<strSize;i++)
    {
        //must detect in same time,一开始if-else,造成AAA型丢失奇数对称的情况
        if(i+1<strSize&&str[i]==str[i+1])
            tmp1=longestStr(str,i,i+1,strSize);
        if(i+2<strSize&&str[i]==str[i+2])
            tmp=longestStr(str,i,i+2,strSize);
        tmp=tmp>tmp1?tmp:tmp1;
        longest=tmp>longest?tmp:longest;
    }
    cout<<longest<<endl;
    return 0;
}
  • AC
    1040
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值