关闭

Theme.AppCompat.Light无法找到问题

165人阅读 评论(0) 收藏 举报
分类:

使用adt开发新建一个Android app,选择支持的SDK版本如果小于11(Android3.0)就会报如下错误。

error: Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Light'.

官网给出的答案是:

https://developer.android.com/tools/support-library/setup.html#add-library

简单来说就是新的eclipse默认模版主题UI需要使用比较高版本api,如果需要支持低版本,需要导入appCompact库来支持,网上一般给出的解法:

  1. File->Import (android-sdk\extras\android\support\v7). Choose "appcompat"
  2. Project-> properties->Android. In the section library "Add" and choose "appCompat"
包括stackoverflow上也有很多人遇到,但很多人通过这个解决,但我就是没办法解决。

后来发现这个是eclipse的bug,如果你引用的库和你的代码不在一个盘符,就有此异常
我的代码在E盘,appCompact的库在D盘,我从新将其移动到E盘就ok。
fuck,浪费好多时间。
有遇到同样问题的可参考。
0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:295383次
    • 积分:4942
    • 等级:
    • 排名:第5757名
    • 原创:92篇
    • 转载:765篇
    • 译文:4篇
    • 评论:16条
    最新评论