HDU - 1452 - Happy 2004 - (因子和,极性函数,同余逆元)

转自:http://www.cnblogs.com/372465774y/archive/2012/10/22/2733977.html

Happy 2004

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 673    Accepted Submission(s): 481


Problem Description
Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.
 
 
Input
The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000). A test case of X = 0 indicates the end of input, and should not be processed.
 
 
Output
For each test case, in a separate line, please output the result of S modulo 29.
 
 
Sample Input
1
10000
0
 
 
Sample Output
6
10
 
 
Source
 
 
Recommend
lcy
求约数的和
首先 约束和函数是积性函数(就是如果m,n互质,则 f(mn)=f(m)f(n))
  还有约数个数函数也是积性函数 这2个比较好证明 直接带入就可以
S(x)代表x的约数和
S(20)=S(4)*S(5)
如果p是素数 S(p^n)=1+p+p^2+...p^n=(p^(n+1)-1)/(p-1);
所以本题 S(2004^x)=(2^(2*x+1)-1)(3^(x+1)-1)/2*(167^(x+1)-1)/166

而又同余性质  : 若 a=b(mod m) 则 a^k=b^k (mod m):
所以 167可以用 22代替,(对29 同余)
对于  a^k*b^h*...%m的题目 直接二进制快速运算
这里还有个 a^k/d % m
这就相当于 a^k*d-1%m
d-1 是 d的模m逆  就是  dd-1=1 mod m  ...1
这样的话               a^k/b=x mod m ...2
                  由1,2根据同余性质 a^k*d-1=x mod m
所以本题就Ok了

#include <iostream>
#include <map>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int Mod(int a,int b)
{
    int t;
    for(t=1;b>0;b>>=1,a=(a*a)%29)
     if(b&1) t=(t*a)%29;
    return t;
}
int main()
{
    int n;
    int a,b,c;
    while(scanf("%d",&n),n)
    {
         a=(Mod(2,2*n+1)-1);
         b=(Mod(3,n+1)-1)*15; 15是2的mod 29逆
         c=(Mod(22,n+1)-1)*18;18是 21的mod 29逆
         printf("%d\n",a*b*c%29);
    }

    return 0;
}


另外参考:

乘法逆元

http://blog.csdn.net/yeguxin/article/details/46669831

http://blog.sina.com.cn/s/blog_79b832820100xx20.html
http://blog.csdn.net/luyuncheng/article/details/8017016

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值