Billboard (线段树更新叶子节点)

点击打开链接Billboard

1、题目大意:

在大学门口,有一个高位h 宽为w的广告牌,现在广告牌是空的,有一些小的广告要张贴到广告牌上,已知这些小广告的高度都是1,宽为wi,张贴有一定规律,按照顺序来,并且往最高处贴,如果最高处贴不开就往下一行贴,输出每一张广告贴在的行,若果广告牌上贴不开,就输出-1

思路:

将展板90度旋转,即可将长度作为叶子节点

2、题目:

Billboard

Time Limit : 20000/8000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1
Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.


 

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.


 

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.


 

Sample Input
  
  
3 5 5 2 4 3 3 3


 

Sample Output
  
  
1 2 1 3 -1

3、代码:

#include<stdio.h>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int max[200005*4];
int w;
int maxNum(int x,int y)
{
    return x>y?x:y;
}
void build(int l,int r,int rt)
{
    max[rt]=w;
    if(l==r)
        return ;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
int query(int x,int l,int r,int rt)
{
    if(l==r)
    {
        max[rt]-=x;
        return l;
    }
    int m=(l+r)>>1,ret;
    if(x<=max[rt<<1])
        ret=query(x,lson);
    else ret=query(x,rson);
    max[rt]=maxNum(max[rt<<1],max[rt<<1|1]);
    return ret;
}
int main()
{
    int h,n,x;
    while(scanf("%d%d%d",&h,&w,&n)!=EOF)
    {
        if(h>n)
        h=n;//取小的即可
        build(1,h,1);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            if(x>max[1])
            printf("-1\n");
            else
            printf("%d\n",query(x,1,h,1));
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值