poj 3692 (二分图最大团)

Kindergarten
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4026 Accepted: 1933

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

题意:女孩子相互认识,男孩子也相互认识,男女之间有部分认识,问最多有多少人相互认识。

相关概念定理:

1.独立集:任意两点都不相连的顶点的集合 

2.定理:最大独立集=顶点数-最大匹配边数(二分图当然也成立)

3.完全子图:任意两点都相连的顶点的集合(最大完全子图即最大团)  

4.定理:最大团=原图补图的最大独立集

所以根据第四条可以看出在二分图中最大团问题可以方便解决,但在一般图中为NP问题。

 

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define maxm 405
int n,m,s;
int map[maxm][maxm],vis[maxm],link[maxm];//map存图
int dfs(int t)
{
    for(int i=1;i<=m;i++)
    {
        if(vis[i]==0&&map[t][i])
        {
            vis[i]=1;
            if(link[i]==-1||dfs(link[i]))
            {
                link[i]=t;
                return 1;
            }
        }
    }
    return 0;
}
int MaxMatch()
{
    int num=0;
    memset(link,-1,sizeof(link));
    for(int i=1;i<=n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i))
        num++;
    }
    return num;
}
int main()
{
    int a,b,cas=1;
    while(cin>>n>>m>>s)
    {
        if(n==0&&m==0&&s==0)break;
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        map[i][j]=1;
        for(int i=0; i<s; i++)
        {
            cin>>a>>b;
            map[a][b]=0;
        }
        cout<<"Case "<<cas++<<": "<<n+m-MaxMatch()<<endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值