闪屏页面开发遇到的问题you need to use a theme.appcompat theme (or descendant)

原创 2015年11月21日 18:36:08

开始做一个新闻客户端的应用,在做到闪屏页面时之前发布应用的时候总是报错,原因是我在splash.java中把Activty写成ActionBarActivity,导包,然后就可以了。以前也遇到过这种情况,真是不应该再一次犯这种错误啊!

版权声明:文章版权归作者所有,未经同意严禁转载!

Android问题集锦之二十八:You need to use a Theme.AppCompat theme (or descendant) with this activity.

错误描述为:java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) with ...
  • lincyang
  • lincyang
  • 2015年01月13日 17:49
  • 120193

解决Android: You need to use a Theme.AppCompat theme (or descendant) with this activity.

今天继续读郭少的>,在研究2.4.4体验活动的生命周期,根据书上代码重新敲了一遍,在点击Start DialoyActivity按钮时,程序后台报错,如下: /AndroidRuntime: Shut...
  • zhangshufei8001
  • zhangshufei8001
  • 2017年03月28日 11:43
  • 491

使用ActionBar,调整Theme时遇到You need to use a Theme.AppCompat theme (or descendant) with this activity解决方法

今天在写一个ActionBar时,想把标题颜色改成白色,以匹配app的风格,默认是黑色的:         这种黑色的标题栏,原因是因为清单文件AndroidMani...
  • cyp331203
  • cyp331203
  • 2015年04月06日 10:19
  • 2268

you need to use a theme.appcompat theme (or descendant) with this activity 解决办法

当你想隐藏 Androidmanifest.xml android:n
  • xuqingfeng77
  • xuqingfeng77
  • 2015年05月28日 11:01
  • 7859

我的Android进阶之旅------>解决错误:You need to use a Theme.AppCompat theme (or descendant) with this activity.

1、错误描述今天,想实现Activity不显示标题栏的效果,在项目的AndroidManifest.xml文件,对相应的Activity添加属性 android:theme="@android:sty...
  • qq446282412
  • qq446282412
  • 2016年05月06日 21:27
  • 24760

android studio编程时出现的错误:you need to use a theme.appCompat theme(or descendant) with this a

用Android Studio中导入第三方库工程的时候出现的问题: java.lang.illegalStateException : you need to use a theme.appComp...
  • qq_22078107
  • qq_22078107
  • 2016年11月28日 14:13
  • 695

关于“you need to use a theme.appcompat theme (or descendant) with this activity”错误

在写一个应用的界面的时候,我xiangb
  • u012336923
  • u012336923
  • 2014年09月23日 12:59
  • 4220

关于新版SDK报错You need to use a Theme.AppCompat theme的两种解决办法

android的一个小问题:   Caused by: java.lang.IllegalStateException: You need to use a Theme.AppCompat...
  • cyp331203
  • cyp331203
  • 2014年08月15日 19:39
  • 5802

【我的Android进阶之旅】解决bug:You need to use a Theme.AppCompat theme (or descendant) with this activity.

前言今天用Android Studio 生成Activity的时候,默认继承AppCompatActivity ,而在AndroidManifest.xml我对该Activity设置了一个主题,然后运...
  • qq446282412
  • qq446282412
  • 2016年10月17日 16:21
  • 2268

Studio报错 You need to use a Theme.AppCompat theme的两种解决办法

Caused by: java.lang.IllegalStateException: You need to use a Theme.AppCompat theme (or descendant) ...
  • amor5216
  • amor5216
  • 2016年03月01日 01:48
  • 1949
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:闪屏页面开发遇到的问题you need to use a theme.appcompat theme (or descendant)
举报原因:
原因补充:

(最多只允许输入30个字)