hdu 1116(欧拉图典型应用)

参考百度文库https://wenku.baidu.com/view/b245abaad1f34693daef3eae.html

欧拉回路 不重复地经过每条边的回路。

欧拉路径 不重复地经过每条边的路径。

欧拉图  存在欧拉回路的图。

半欧拉图 存在欧拉路径的图。

无向欧拉图的判定

¡无向图存在欧拉回路的充要条件:
连通且没有奇点。

¡

¡无向图存在欧拉路径的充要条件:
连通且奇点个数为2。


有向欧拉图的判定

¡有向图存在欧拉回路的充要条件:
基图连通且所有顶点入度等于出度。
¡
¡有向图存在欧拉路径的充要条件:
基图连通且存在某顶点入度比出度大1,另一顶点出度比入度大1,其余顶点入度等于出度。
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list. 
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.


这道题典型的应用到欧拉图,先用并查集检查是否连通,再挨个找出入口。该题为有向欧拉图。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int pre[100];
int in[100];
int out[100];
int flag;
int vist[30];

int fin(int x)
{
    int r = x;
    while(r != pre[r])
    {
        r = pre[r];
    }
    return r;
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t --)
    {
        int n;
        flag = 1;
        scanf("%d", &n);
        memset(out,0,sizeof(out));
        memset(in,0,sizeof(in));
        memset(vist,0,sizeof(vist));

        for(int i = 1; i <= 30; i ++)
            pre[i] = i;
        for(int i = 1; i <= n; i ++)
        {
            string s;
            cin>>s;
            int ben = s[0] - 'a' + 1;
            int en = s[s.size() - 1] - 'a' + 1;
            int x = fin(ben);
            int y = fin(en);
            vist[ben] = 1;
            vist[en] = 1;
            out[ben]++;
            in[en] ++;
            if(x != y)
                pre[y] = x;
        }

        int cnt = 0;
        for(int i = 1; i <= 26; i ++)
        {
            if(vist[i] && pre[i] == i)
                cnt++;
        }
        if(cnt != 1)
        {
            printf("The door cannot be opened.\n");
            continue;
        }
        int start = 0,ed = 0;
        for(int i = 1; i <= 26; i ++)
        {
            if(vist[i] && in[i]!=out[i])
            {
                int tem = in[i] - out[i];
                if(tem == - 1)
                {
                    start ++;
                }
                else if(tem == 1)
                {
                    ed ++;
                }
                else
                {
                    flag = 0;
                }
            }
        }
        if((flag&&start == 1&&ed == 1)||(flag&&start == 0&&ed == 0))
            printf("Ordering is possible.\n");
        else
            printf("The door cannot be opened.\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值