poj 1265 Area(几何 皮克定理 )

Area
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6261 Accepted: 2753

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

 
Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

Source

题目大意:给出每个点相对于前一个点的坐标增量,增量都是整数,会得到一个在网格上多边形,求多边形内的格点、多边形上的格点以及多边形的面积。


解题思路:这个题主要是Pick定理的应用(Pick定理传送门),另外还有几个其他的知识点。

Pick定理:平面上以格子点为顶点的简单多边形的面积=边上的点数/2+内部的点数-1。

计算多边形边上的格点数目:Σ ( GCD ( abs(dx),  abs(dy)) )  dx是每个点相对于前一个点的x的增量, dy是每个点相对于前一个点的y的增量。

1、以格子点为顶点的线段,覆盖的点的个数为GCD(dx,dy),其中,dxdy分别为线段横向占的点数和纵向占的点数。如果dx或dy为0,则覆盖的点数为dy或dx。
2、Pick公式:平面上以格子点为顶点的简单多边形的面积=边上的点数/2+内部的点数-1。

3、任意一个多边形的面积等于按顺序求相邻两个点与原点组成的向量的叉积之和。

#include<stdio.h>
#include<math.h>
using namespace std;
struct node
{
    int x,y;
}s[110];

int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}

int getarea(struct node a,struct node b)
{
    return a.x*b.y-a.y*b.x;
}

int main()
{
    int t;
    int n,m;
    int i,j;

    double area;
    int on_edge;
    int in_edge;
    int dx,dy;


    int count = 0;
    scanf("%d",&t);
    while(t--)
    {
        count++;
        scanf("%d",&n);

        s[0].x=0;
        s[0].y=0;
        area  = 0;
        on_edge = 0;

        for( i = 1;i <=n ; i++)
        {
            scanf("%d%d",&dx,&dy);

            s[i].x = s[i-1].x+dx;
            s[i].y = s[i-1].y+dy;

            on_edge+=gcd( fabs(dx),fabs(dy) );
            area+=getarea(s[i],s[i-1]);

        }
        if(area<0) area=-area;
        printf("Scenario #%d:\n",count);
        in_edge = (area-on_edge+2)/2;
        printf("%d ",in_edge);
        printf("%d ",on_edge);
        printf("%.1f\n\n",0.5*area);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值