hdu4965——矩阵快速幂优化

传送门:http://acm.split.hdu.edu.cn/showproblem.php?pid=4965

Fast Matrix Calculation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1934    Accepted Submission(s): 887


Problem Description
One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N).
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’.

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.
 

Input
The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.
 

Output
For each case, output the sum of all the elements in M’ in a line.
 

Sample Input
  
  
4 2 5 5 4 4 5 4 0 0 4 2 5 5 1 3 1 5 6 3 1 2 3 0 3 0 2 3 4 4 3 2 2 5 5 0 5 0 3 4 5 1 1 0 5 3 2 3 3 2 3 1 5 4 5 2 0 0
 

Sample Output
  
  
14 56
 

Author
SYSU
 

Source
 

Recommend
We have carefully selected several similar problems for you:   6216  6215  6214  6213  6212 
 

题意:

矩阵A是N*K的矩阵,矩阵B是K*N的矩阵

题目中分条说的很明确,一共有四个步骤

1、计算矩阵C:C=A*B(具体规格是N*N)

2、计算矩阵C的乘方:求C的N*N次方

3、计算矩阵M:矩阵C的每个元素对6取余,得到M

4、求和:将M的每一个元素加起来

输入N,K和矩阵A,B,求出最后的和

思路:这里如果直接按题目中的步骤,是不行的。主要在于N,K的范围,如果按A*B去快速幂,最大是1000*1000的矩阵可能就会超时。但是如果按B*A去快速幂,最大的矩阵是6*6,时间就减少了很多。所以这里要用到一种变形

(A * B) ^ (N * N) = A * (B * A) ^[N * (N-1)] *B

代码:

#include<iostream>
#include<sstream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<ctime>
#include<list>
#include<vector>
#include<set>
#include<map>
#include<stack>
#include<queue>
#pragma GCC optimize("02")
#define cl(a,b) memset(a,b,sizeof(a))
#define in freopen("F://1.txt","r",stdin)
#define out freopen("F://2.txt","w",stdout)
using namespace std;
typedef unsigned long long llu;
typedef long long ll;
const int N = 10;
const int MAXN = 1005;
ll m,n;
ll a[MAXN][MAXN],b[MAXN][MAXN],t1[MAXN][MAXN],t2[MAXN][MAXN];
struct Matrix
{
    int mat[N][N];
    void Init(){
        cl(mat, 0);
    }
    void Unit(){
        cl(mat, 0);
        for (int i = 0; i < N; i++)
            for (int j = 0; j < N; j++)
                mat[i][j] = (i == j);
    }
};
Matrix operator*(Matrix &a,Matrix &b){
    Matrix res;
    res.Init();
    for(int k=0; k<N; ++k){
        for(int i=0; i<N; ++i){
            if(!a.mat[i][k])
                continue;
            for(int j=0; j<N; ++j)
            {
                res.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
                res.mat[i][j]%=6;
            }
        }
    }
    return res;
}
Matrix operator ^(Matrix a,ll k){
    Matrix res;
    res.Init();
    res.Unit();
    while(k){
        if(k%2)
            res=res*a;
        a=a*a;
        k>>=1;
    }
    return res;

}
int main(){
    //in;
    Matrix tmp;
    while(~scanf("%lld%lld",&n,&m)){
        if(n==0&&m==0)
            return 0;
        cl(tmp.mat,0);
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                scanf("%d",&a[i][j]);
        for(int i=0; i<m; i++)
            for(int j=0; j<n; j++)
                scanf("%d",&b[i][j]);
        for(int i=0; i<m; i++)
            for(int j=0; j<m; j++)
            {
                tmp.mat[i][j]=0;
                for(int k=0; k<n; k++)
                {
                    tmp.mat[i][j]+=b[i][k]*a[k][j];
                    tmp.mat[i][j]%=6;
                }
            }
        Matrix p=tmp^(n*n-1);
        for(int i=0; i<n; i++){
            for(int j=0; j<m; j++){
                t1[i][j]=0;
                for(int k=0; k<m; k++){
                    t1[i][j]+=a[i][k]*p.mat[k][j];
                    t1[i][j]%=6;
                }
            }
        }
        for(int i=0; i<n; i++){
            for(int j=0; j<n; j++){
                t2[i][j]=0;
                for(int k=0; k<m; k++)
                {
                    t2[i][j]+=t1[i][k]*b[k][j];
                    t2[i][j]%=6;
                }
            }
        }
        /*for(int i=0; i<n; ++i){
            for(int j=0; j<n; ++j){
                cout<<t2[i][j]<<" ";
            }
            cout<<endl;
        }*/
        ll ans=0;
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                ans+=t2[i][j];
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值