poj-3468A Simple Problem with Integers(线段树对部分数值的改变以及求和)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 96612 Accepted: 30145
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source


#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define N 111111
#define LL __int64
using namespace std;
LL add[N<<2];//保存改变值的大小 
LL sum[N<<2];//保存和 
void pushup(LL rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(LL rt,LL m)
{
	if(add[rt])
	{
		add[rt<<1]+=add[rt];//左子树和右子数需要改变的总的变化量  不直接把每次的变化量传递给每个节点 只是先标记 看最后求和的时候最终改变的大小 加快速度 
		add[rt<<1|1]+=add[rt];
		sum[rt<<1]+=add[rt]*(m-(m>>1));//改变左子树节点的sum值 
		sum[rt<<1|1]+=add[rt]*(m>>1);
		add[rt]=0;//清楚该节点的标记 
	}
}
void build(LL l,LL r,LL rt)
{
	add[rt]=0;
	if(l==r)
	{
		scanf("%I64d",&sum[rt]);
		return;
	}
	LL m=(l+r)>>1;
	build(lson);
	build(rson);
	pushup(rt);
}
void update(LL L,LL R,LL c,LL l,LL r,LL rt)
{
	if(L<=l&&R>=r)
	{
		add[rt]+=c;
		sum[rt]+=(LL)c*(r-l+1);//r-l+1表示r到l区间的节点数量 
		return ;
	}
	pushdown(rt,r-l+1);//更新子节点 
	LL m=(l+r)>>1;
	if(L<=m)
	update(L,R,c,lson);
	if(m<R)
	update(L,R,c,rson);
	pushup(rt);
}
LL query(LL L,LL R,LL l,LL r,LL rt)
{
	if(L<=l&&R>=r)
	{
		return sum[rt];
	}
	pushdown(rt,r-l+1);// 把标记下推 跟新到每个sum 不然会出错 
	LL m=(l+r)>>1;
	LL res=0;
	if(m>=L)
	{
		res+=query(L,R,lson);
	}
	if(m<R)
	{
		res+=query(L,R,rson);
	}
	return res;
}
int main()
{
	LL n,q;
	scanf("%I64d%I64d",&n,&q);
	build(1,n,1);
	while(q--)
	{
		char op[2];
		LL a,b,c;
		scanf("%s",op);
		if(op[0]=='Q')
		{
			scanf("%I64d%I64d",&a,&b);
			printf("%I64d\n",query(a,b,1,n,1));
		} 
		else {
			scanf("%I64d%I64d%I64d",&a,&b,&c);
			update(a,b,c,1,n,1);
		}
	}
	return 0;
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值