hdu-2795Billboard(线段树 找到可以贴当前广告最上方的位置)

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19710    Accepted Submission(s): 8242


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1542  1828  1540  1255  2871 

#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define M 222222
int MAX[M<<2];
int h,w,n;
void pushup(int rt)
{
	MAX[rt]=max(MAX[rt<<1],MAX[rt<<1|1]);//求节点的最大值 
}
void build(int l,int r,int rt)
{
	MAX[rt]=w;//初始化宽度 
	if(l==r)
	return ;
	int m=(l+r)>>1;
	build(lson);
	build(rson);
}
int query(int x,int l,int r,int rt)
{
	if(l==r)
	{
		MAX[rt]-=x;//该行的可以贴广告长度需要减去x 
		return l;
	}
	int m=(l+r)>>1;
	int res;
	if(MAX[rt<<1]>=x)//如果左儿子的长度可以满足x的长度 左子树较小 先判断左子树 后判断右子树 
	{
		res=query(x,lson);
	}
	else res=query(x,rson);
	pushup(rt);//将左右子树更新 减去了x 
	return res;
}
int main()
{
	while(~scanf("%d%d%d",&h,&w,&n))
	{
		if(h>n)h=n;//剪枝 防止h过大 有n个广告 最多h宽度即可 
		build(1,h,1);
		while(n--)
		{
			int x;
			scanf("%d",&x);
			if(MAX[1]<x)//如果长度小于x则一张广告都无法贴 
			printf("-1\n");
			else printf("%d\n",query(x,1,h,1));
		}
	}
	return 0;
} 


 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值