hdu 4565So Easy!(巧妙的矩阵快速幂)

So Easy!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3849    Accepted Submission(s): 1266


Problem Description
  A sequence S n is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
  You, a top coder, say: So easy!
 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.
 

Output
  For each the case, output an integer S n.
 

Sample Input
  
  
2 3 1 2013 2 3 2 2013 2 2 1 2013
 

Sample Output
  
  
4 14 4
 

Source
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:   5867  5866  5865  5864  5863 

/*
告诉你a,b,n,m,求

0<a,m<2^15 , (a-1)^2<b<a^2 , 0<b,n<2^31
解题思路:
我们首先对(a+sqrt(b))^n进行处理,由a+sqrt(b))^n的展开式我们可以知道
(a+sqrt(b))^n = Xn + Yn * sqrt(b);
那么
( a + sqrt( b ) )^( n + 1 ) = ( a + sqrt( b ) ) * ( Xn + Yn * sqrt(b) ) = ( a * Xn + b * Yn ) + ( a * Yn + Xn ) * sqrt( b );
则
Xn+1 = ( a * Xn + b * Yn )
Yn+1 = ( a * Yn + Xn )

所以

Xn = a * X0 + b * Y0;
Yn = X0 + a * Y0;

由于 (a-1)^2<b<a^2 ,
那么 0 < ( a - sqrt( b ) )^ n < 1
 又  ( a + sqrt( b ) )^ n + ( a - sqrt( b ) )^ n = 2 * Xn
那么 ( a + sqrt( b ) )^ n 向上取整的值就是 2 * Xn
最终
    Sn = ( 2 * Xn )% m;
*/

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
typedef long long ll;
struct matrix{
	ll mat[2][2];
};
matrix mul(matrix &a,matrix &b,ll mm)
{
	matrix c;
	for(int i=0;i<2;i++)
	{
		for(int j=0;j<2;j++)
		{
			c.mat[i][j]=0;
			for(int k=0;k<2;k++)
			{
				c.mat[i][j]+=(a.mat[i][k]*b.mat[k][j]);
			}
			c.mat[i][j]%=mm;
		}
	}
	return c;
}
matrix inti()
{
	matrix ans;
	for(int i=0;i<2;i++)
	{
		for(int j=0;j<2;j++)
		ans.mat[i][j]=(i==j);
	}
	return ans;
}
matrix ks(matrix a,ll k,ll mm)
{
	matrix ans=inti();
	while(k)
	{
		if(k&1)
		ans=mul(ans,a,mm);
		a=mul(a,a,mm);
		k>>=1;
	}
	return ans;
}
int main()
{
	matrix M;
	ll a,b,n;
	ll m;
	while(~scanf("%lld%lld%lld%lld",&a,&b,&n,&m))
	{
		M.mat[0][0]=a;
		M.mat[1][1]=a;
		M.mat[0][1]=b;
		M.mat[1][0]=1;
		matrix ans=ks(M,n,m);
		ll x=ans.mat[0][0];
		cout<<(2*x)%m<<endl;
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值