【Shawn-poj】Binary Tree

北大的学长坑我的一道题,首先先问候一下他https://liwyno.github.io/

然后我们来看题:

2499:Binary Tree

总时间限制:
1000ms
内存限制:
65536kB
描述
Background
Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this:
  • The root contains the pair (1, 1).
  • If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem
Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?
输入
The first line contains the number of scenarios.
Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*10 9) that represent
a node (i, j). You can assume that this is a valid node in the binary tree described above.
输出
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.
样例输入
3
42 1
3 4
17 73
样例输出
Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6
来源

TUD Programming Contest 2005 (Training Session), Darmstadt, Germany


翻译一下题目,感谢谷歌翻译:

(题目有个right翻译错了,然后意思就莫名其妙的了)


先上答案:一个整函数哈,好久没有写c了,最近想考研,所以数据结构看的比较多,就练练手,本题目的关键是化减为除(由于编译器的问题,我们可以有结果后立即打印,无需开辟空间保存结果,最后一起输出),然后类似找规律题,不要把题目想的那么复杂。

#include <stdio.h>
int main(){
	int n=0;
	scanf("%d",&n);
	int i=0;
	int a=0,b=0,c=0,d=0;
	int cnt=1;
	while(n--){
		scanf("%d",&a);
		scanf("%d",&b);
		c=0,d=0;
		while(a!=1||b!=1){
			if(a>b){
				c+=(a/b);
				if(a%b==0){
					a=1;
					c--;
				}
				else a%=b;
			}
			else{
				d+=(b/a);
				if(b%a==0){
					b=1;
					d--;
				}
				else b%=a;
			}
			
		}
		printf("Scenario #%d:\n",cnt++);
		printf("%d",c);
		printf(" %d\n\n",d);
	}
		
	return 0;
}

原本写法是:

if(a>b){c++;a-=b}
else{b-=a}

这样的话,理论上是没有错的,但是学霸一下子点醒了我,如果输入为(1,10^9)那么这个语句将执行10^9次,感觉肯定会超时,所以用了除法,除法后有一个整除的问题稍微留意一下,要减去一,令为一的操作。




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值