POJ 1323 Game Prediction(贪心)

Game Prediction
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 



Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game. 

Input

The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros. 

Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game. 

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4

分析:M个人,每人N张牌,每轮比较谁出的牌大,最大者为胜。现在给定M和N,以及你的牌,要求输出你至少能确保获得几轮的胜利
举个例子吧,第二个样例
6 11
62 63 54 66 65 61 57 56 50 53 48
首先对手中的牌做一个降序排列,即
66 65 63 62 61 57 56 54 53 50 48
66和65肯定必胜,63因为外面有64,所以不能保证必胜,62必胜(因为64已经被63消耗掉了),61必胜(同理),后面都都没有必胜可能了
所以,理清思路,就可以写代码了:

AC代码:

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct sgm
{
    int pip;
} a[1010];
bool cmp(sgm A,sgm B)
{
    if(A.pip!=B.pip)
        return A.pip>B.pip;
}
int main()
{
    int n,m,i,j,sec=1,max,s=1;
    while(scanf("%d %d",&n,&m)&&n+m)
    {
        for(i=0; i<m; i++)
            scanf("%d",&a[i].pip);
        sort(a,a+m,cmp);
        //for(i=0;i<m;i++)
        //  printf("%d ",a[i].pip);
        int l=0,c=0;
        for(max=n*m,i=0; i<m&&max>0; max--)
        {
            if(max==a[i].pip)
            {
                i++;
                if(l==0)
                    c++;
                else l--;
            }
            else l++;
        }
        printf("Case %d: %d\n",s++,c);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值