poj3083Children of the Candy Corn

Children of the Candy Corn
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9947 Accepted: 4320

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit. 

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.) 

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'. 

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#'). 

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5

17 17 9

题意:一个迷宫,从s到e,求出一直沿着左手边走所需的步数,求出一直沿着右手边所需的步数,求出最少步数

注意:s跟e一定在边缘地带,求步数的时候要加上起点和终点

注意:第一个和第二个用深搜,不需要标记数组,因为走过之后可能还会倒过来再走,第三个用普通广搜就可以做

#include <iostream>
#include <cstdio>
#include <queue>

using namespace std;

struct node
{
    int x, y, step;
};
int row, col, sx, sy, ex, ey, ans;
char maze[45][45];
int di[4][2] = {{1, 0}, {-1, 0}, {0, 1},{0, -1}};
int l[4][2] = {{0, 1}, {1, 0}, {0, -1}, {-1, 0}};//左边方向
int r[4][2] = {{0, 1}, {-1, 0}, {0, -1}, {1, 0}};//右边方向
int bfs()//求最短步数,普通的用广搜就可以做
{
    queue <node> q;
    node no = {sx, sy, 0};
    q.push(no);
    maze[no.x][no.y] = '#';//在原地图上改,不需要标记数组
    int i, current_x, current_y;
    while(!q.empty())
    {
        no = q.front();
        if(no.x == ex && no.y == ey)
        {
            break ;
        }
        q.pop();
        for(i = 0; i < 4; i++)
        {
            current_x = no.x + di[i][0];
            current_y = no.y + di[i][1];
            if(current_x >= 0 && current_x < row && current_y >= 0 && current_y <col)
            {
                if(maze[current_x][current_y] == '.' || maze[current_x][current_y] == 'E')//这儿要加上e这个判断条件,否则会找不到路
                {
                    node de = {current_x, current_y, no.step + 1};
                    q.push(de);
                    maze[current_x][current_y] = '#';
                }
            }
        }
    }
    return no.step + 1;//因为题目里要求是一起计算起点和终点,所以要+1
}
int dfs_l(int x, int y, int step)//沿着左边深搜
{
    if(x == ex && y == ey)//一旦找到就返回步数
    {
        return step + 1;
    }
    if(x < 0 || y < 0|| x >= row || y >= col || maze[x][y] == '#')//判断是否越界和是否碰到了墙
    {
        return 0;
    }
    int temp = 0;
    ans = (ans + 3) % 4;//这里主要是为了设置当前方向
    while(1)
    {
        temp = dfs_l(x + l[ans][0], y + l[ans][1], step + 1);
        if(temp > 0)
        {
            break ;
        }
        ans = (ans + 1) % 4;//这里是回溯的时候进入下一个方向
    }
    return temp;//如果找到,返回主函数
}
int dfs_r(int x, int y, int step)//沿着右边深搜找路,类似于左边深搜
{
    if(x == ex && y == ey)
    {
        return step + 1;
    }
    if(x < 0 || y < 0|| x >= row || y >= col || maze[x][y] == '#')
    {
        return 0;
    }
    int temp = 0;
    ans = (ans + 3) % 4;
    while(1)
    {
        temp = dfs_r(x + r[ans][0], y + r[ans][1], step + 1);
        if(temp > 0)
        {
            break ;
        }
        ans = (ans + 1) % 4;
    }
    return temp;
}
int main()
{
    int n, i, j;
    scanf("%d", &n);
    while(n--)
    {
        scanf("%d%d", &col, &row);
        for(i = 0; i < row; i++)
        {
            getchar();
            scanf("%s", maze[i]);
            for(j = 0; j < col; j++)
            {
                if(maze[i][j] == 'S')
                {
                    sx = i;
                    sy = j;
                }
                if(maze[i][j] == 'E')
                {
                    ex = i;
                    ey = j;
                }
            }
        }
        ans = 0;
        printf("%d ", dfs_l(sx, sy, 0));
        ans = 0;
        printf("%d ", dfs_r(sx, sy, 0));
        printf("%d\n", bfs());
      /*  for(i = 0; i < row; i++)
        {
            printf("%s\n", maze[i]);
        }*/
    }
    return 0;
}


深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值