LA 3635 - Pie 【二分】

Regionals 2006 >> Europe - Northwestern
3635 - Pie

Time limit: 3.000 seconds
My birthday is coming up and traditionally I’m
serving pie. Not just one pie, no, I have a number
N of them, of various tastes and of various sizes. F
of my friends are coming to my party and each of
them gets a piece of pie. This should be one piece
of one pie, not several small pieces since that looks
messy. This piece can be one whole pie though.
My friends are very annoying and if one of them
gets a bigger piece than the others, they start complaining.
Therefore all of them should get equally
sized (but not necessarily equally shaped) pieces,
even if this leads to some pie getting spoiled (which
is better than spoiling the party). Of course, I want
a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and
they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:
• One line with two integers N and F with 1 ≤ N, F ≤ 10000: the number of pies and the number
of friends.
• One line with N integers ri with 1 ≤ ri ≤ 10000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can
all get a pie piece of size V . The answer should be given as a oating point number with an absolute
error of at most 10−3
.
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655

题意:有n个pie,有f+1个人,每个人都要一整块(不是拼的)的等其他人面积的pie,求最大面积是多少。
思路:二分0~面积最大的。因为是整块分,我们只需要判断最后分的块数是不是大于等于F+1即可。
代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
const int M = 1e4+5;
const double Pi = acos(-1.0);

int n, f;
double s[M];

bool ok(double x){
    int sum = 0;
    for(int i = 0; i < n; ++ i) sum += floor(s[i]/x);
    if(sum >= f+1) return 1;
    return 0;
}

int main(){
    int t, v = 0;
    scanf("%d", &t);
    while(t --){
        scanf("%d%d", &n, &f);
        double temp, Max = -10000;
        for(int i = 0; i < n; ++ i){
            scanf("%lf", &temp);
            s[i] = temp*temp*Pi;
            Max = max(Max, s[i]);
        }
        double left = 0, right = Max;
        while(right - left > 1e-3){
            double mid = (right+left)/2;
            if(ok(mid)) left = mid;
            else right = mid;
        }
        printf("%.4lf\n", right);
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值