Dynamic Web Module 是2.3,无法修改到3.0

原创 2016年08月29日 14:32:25

eclipse 新SVN下来的项目,遇到了这样的问题:
这里写图片描述
打开
project > Properties >Project Facets 页面
提示下面的错误:
这里写图片描述
而Dynamic Web Module 是2.3,无法修改到3.0,Java 已经是1.7了
非常郁闷。
pom.xml里也已经有了配置:

    <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>2.3.2</version>
                <configuration>
                    <source>1.7</source>
                    <target>1.7</target>
                </configuration>
    </plugin>

如何解决问题?百度了很久,看了一些文章,基本方法就是改Java version,并在pom.xml中添加上述设置。但是不管用怎么办?
最后有一个终极方法直接修改Dynamic Web Module:
在navigator视图下找到.setting包下的org.eclipse.wst.common.project.facet.core.xml
修改

<installed facet="jst.web" version="2.3"/>

<installed facet="jst.web" version="3.0"/>

OK!

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

eclipse如何修改dynamic web module version

java项目中,若切换服务器,经常会涉及到动态web模块版本的问题。      比如:新建了web项目,开始使用tomcat服务器,但是后来使用jboss服务器,就会出现:Project face...

配置MyEclipse中Dynamic Web Module 3.0版本时报错

在MyEclipse中使用maven创建web-app的过程中总会遇到一个问题,cannot change version of project facet dynamic web module to...

解决Eclipse建Maven项目Dynamic web Module无法转换为2.5

Maven项目在Project Facets里面修改Dynamic web module为2.5的时候就会出现Cannot change version of project facet Dynami...
  • dy_0708
  • dy_0708
  • 2017年02月10日 11:10
  • 1694

eclipse修改Dynamic web module 版本为3.1

1、进入项目下的.settings文件夹 打开org.eclipse.wst.common.project.facet.core.xml ...

eclipse如何修改dynamic web module version

eclipse如何修改dynamic web module version 一、修改工程属性: 右键eclipse的工程,选择属性,再选择Project Facets里面中选择Dynamic We...

彻底解决Dynamic Web Module 3.0 requires Java 1.6 or newer.

最近在做版本切换的时候经常遇到的一个问题就是Dynamic Web Module 3.0 requires Java 1.6 or newer.可以说是弄到恶心的地步了,还好不是什么大问题经过一天的努...

Eclipse- Dynamic Web Module 3.0 requires Java 1.6 错误

错误信息如图: 发现解决这个问题的有好几个地方,这个要具体看你项目的情况,这边整理了一下: 一、在pom文件中定义maven-compile-plugin的版本跟source、...

解决Cannot change version of project facet Dynamic web module to 2.5

一般我们用Eclipse创建Maven项目的时候

eclipse java web 版本修改问题 3.0-2.5

这个是正常修改的,但是高版本向低版本改的时候有会报错:cannot change version of project facet dynamic web module to 2.5 可以修改项目中...

解决“Maven项目中的Dynamic Web Module 3.0 requires Java 1.6 or newer”问题

错误描述 当创建有动态web模块3.0支持的项目时,需要用到Java版本不低于1.6。 在Markers标签页中显示的错误为:Dynamic Web Module 3.0 requires Java ...
  • conansix
  • conansix
  • 2014年07月05日 21:25
  • 14689
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Dynamic Web Module 是2.3,无法修改到3.0
举报原因:
原因补充:

(最多只允许输入30个字)