poj解题报告——poj 1493 Machined Surfaces

原题入口

poj 1493 Machined Surfaces

题目描述

Machined Surfaces
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3696 Accepted: 2268

Description
An imaging device furnishes digital images of two machined surfaces that eventually will be assembled in contact with each other. The roughness of this final contact is to be estimated.

A digital image is composed of the two characters, “X” and ” ” (space). There are always 25 columns to an image, but the number of rows, N, is variable. Column one (1) will always have an “X” in it and will be part of the left surface. The left surface can extend to the right from column one (1) as contiguous X’s.

Similarly, column 25 will always have an “X” in it and will be part of the right surface. The right surface can extend to the left from column 25 as contiguous X’s.

Digital-Image View of Surfaces

     Left                                  Right



     XXXX                                      XXXXX  ←1

     XXX                                     XXXXXXX

     XXXXX                                      XXXX

     XX                                       XXXXXX

     .                                             .

     .                                             .

     .                                             .

     XXXX                                       XXXX

     XXX                                       XXXXX  ←N

    ↑                                              ↑

    1                                              25

In each row of the image, there can be zero or more space characters separating the left surface from the right surface. There will never be more than a single blank region in any row.

For each image given, you are to determine the total void" that will exist after the left surface has been brought into contact with the right surface. Thevoid” is the total count of the spaces that remains between the left and right surfaces after theyhave been brought into contact.

The two surfaces are brought into contact by displacing them strictly horizontally towards each other until a rightmost “X” of the left surface of some row is immediately to the left of the leftmost “X” of the right surface of that row. There is no rotation or twisting of these two surfaces as they are brought into contact; they remain rigid, and only move horizontally.

Note: The original image may show the two surfaces already in contact, in which case no displacement enters into the contact roughness estimation.

Input
The input consists of a series of digital images. Each image data set has the following format:

First line -
A single unsigned integer, N, with value greater than zero (0) and less than 13. The first digit of N will be the first character on a line.

Next N lines -
Each line has exactly 25 characters; one or more X’s, then zero or more spaces, then one or more X’s.

The end of data is signaled by a null data set having a zero on the first line of an image data set and no further data.

Output
For each image you receive as a data set, you are to reply with the total void (count of spaces remaining after the surfaces are brought into contact). Use the default output for a single integer on a line.

Sample Input

4
XXXX XXXXX
XXX XXXXXXX
XXXXX XXXX
XX XXXXXX
2
XXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXX
1
XXXXXXXXX XX
0

Sample Output

4
0
0

Source
East Central North America 1995

解题代码

#include <iostream>
#include <cstring>
using namespace std;

#define STRING_LEN 26
char szInputMsg[STRING_LEN] = {0};

int main()
{
    int N;
    while((cin >> N) && N)
    {
        cin.get();  // 去除'\n'
        int nTotalSapce = 0;
        int nMinLineSapce = STRING_LEN;
        for (int nLine = 0; nLine < N; ++nLine)
        {
            cin.getline(szInputMsg, STRING_LEN);
            int nLineSpaceCount = 0;
            for (int nIndex = 0; nIndex < STRING_LEN - 1; ++nIndex)
            {
                if (szInputMsg[nIndex] == ' ')
                    ++nLineSpaceCount;
                else if (nLineSpaceCount > 0)
                    break;
            }
            nTotalSapce += nLineSpaceCount;

            if (nLineSpaceCount < nMinLineSapce)
                nMinLineSapce = nLineSpaceCount;
        }
        cout << nTotalSapce - (N * nMinLineSapce) << endl;
    }

    return 0;
}

解题过程

  • 题意:一幅图片是由N行字符串构成,每一行由字母X和空格构成,共有25个字符,并且每行字符以X开头并且以X结尾,由中间连续的空格(0个-23个)分隔,分为左串和右串,题问同时移动各行左串,当有一行的左右X相接时,N行字符串中间的空格有多少!

  • 思路:找出N行的字符串中空格最少的一行,记录其个数”MinSapce”,然后用最初的空格总数减去N*MinSapce即可得到索要的输出结果。

提交结果

poj1493结题报告

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

AlbertS

常来“玩”啊~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值