ZOJ 1203 Swordfish 最小生成树 Kruscal && Prim

ZOJ Problem Set - 1203
Swordfish

Time Limit: 2 Seconds      Memory Limit: 65536 KB

There exists a world within our world
A world beneath what we call cyberspace.
A world protected by firewalls,
passwords and the most advanced
security systems.
In this world we hide
our deepest secrets,
our most incriminating information,
and of course, a shole lot of money.
This is the world of Swordfish.

  We all remember that in the movie Swordfish, Gabriel broke into the World Bank Investors Group in West Los Angeles, to rob $9.5 billion. And he needed Stanley, the best hacker in the world, to help him break into the password protecting the bank system. Stanley's lovely daughter Holly was seized by Gabriel, so he had to work for him. But at the last moment, Stanley made some little trick in his hacker mission: he injected a trojan horse in the bank system, so the money would jump from one account to another account every 60 seconds, and would continue jumping in the next 10 years. Only Stanley knew when and where to get the money. If Gabriel killed Stanley, he would never get a single dollar. Stanley wanted Gabriel to release all these hostages and he would help him to find the money back.
  You who has watched the movie know that Gabriel at last got the money by threatening to hang Ginger to death. Why not Gabriel go get the money himself? Because these money keep jumping, and these accounts are scattered in different cities. In order to gather up these money Gabriel would need to build money transfering tunnels to connect all these cities. Surely it will be really expensive to construct such a transfering tunnel, so Gabriel wants to find out the minimal total length of the tunnel required to connect all these cites. Now he asks you to write a computer program to find out the minimal length. Since Gabriel will get caught at the end of it anyway, so you can go ahead and write the program without feeling guilty about helping a criminal.

Input:
The input contains several test cases. Each test case begins with a line contains only one integer N (0 <= N <=100), which indicates the number of cities you have to connect. The next N lines each contains two real numbers X and Y(-10000 <= X,Y <= 10000), which are the citie's Cartesian coordinates (to make the problem simple, we can assume that we live in a flat world). The input is terminated by a case with N=0 and you must not print any output for this case.

Output:
You need to help Gabriel calculate the minimal length of tunnel needed to connect all these cites. You can saftly assume that such a tunnel can be built directly from one city to another. For each of the input cases, the output shall consist of two lines: the first line contains "Case #n:", where n is the case number (starting from 1); and the next line contains "The minimal distance is: d", where d is the minimal distance, rounded to 2 decimal places. Output a blank line between two test cases.

Sample Input:
5
0 0
0 1
1 1
1 0
0.5 0.5
0

Sample Output:
Case #1:
The minimal distance is: 2.83
 
注-此题为:  ZOJ 1203 Swordfish

说明:最小生成树   Kruscal && Prim  , //格式问题 很坑 

已AC代码:( Kruscal 

#include<cstdio>
#include<cstring>
#include<cmath>
#define M 25000
#include<algorithm>
using namespace std;

int per[300];   // 并查集 
double x[300],y[300];
int n,m;

struct node{
	int u,v;
	double w;   //w为距离 
}s[M];

bool cmp(node a,node b)
{
	return a.w<b.w;
}

double dlen(int i,int j)
{
	return sqrt( (x[i]-x[j])*(x[i]-x[j]) + (y[i]-y[j])*(y[i]-y[j]) );
}

void into()     //初始化 
{
	for(int i=0;i<=n;++i)
		per[i]=i;
}

int find(int x)    // 查找根节点 
{
	return x==per[x]?x:per[x]=find(per[x]);
}

bool join(int a,int b)    //合并根节点,并判断是否成环 
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
	{
		per[fa]=fb;
		return true;
	}
	return false;
}

int main()
{
	int i,j,cas=0;
	while(scanf("%d",&n),n)
	{
		for(i=1;i<=n;++i)
			scanf("%lf%lf",&x[i],&y[i]);
		int k=0;	
		for(i=1;i<n;++i)   //读入数据 
		{
			for(j=i+1;j<=n;++j)
			{
				s[k].u=i;
				s[k].v=j;
				s[k].w=dlen(i,j);
				k++;
			}
		}
		into();   //初始化根节点 
		sort(s,s+k,cmp);    //按距离从小到大排序 
		double sum=0;
		for(i=0;i<k;++i)
		{
			if(join(s[i].u,s[i].v))
			{
				sum+=s[i].w;	
			}
		}
		if(cas>0)  // 格式问题 很坑 
			printf("\n");
		printf("Case #%d:\n",++cas);
		printf("The minimal distance is: %.2lf\n",sum);
	}
	return 0;
}


已AC代码:(Prim

#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 0xfffffff

double x[300],y[300],sum;  //最小生成树权值和 
int n,m;
int vis[300];    //map二维数组存图,low记录每2个点间最小权值,vis标记某点是否已访问
double map[300][300],low[300];

double dlen(int i,int j)
{
	return sqrt( (x[i]-x[j])*(x[i]-x[j]) + (y[i]-y[j])*(y[i]-y[j]) );
}

void prim()
{
	memset(vis,0,sizeof(vis));
	int i,j,pos,t;
	double MIN;
	
	for(i=1;i<=n;++i)  	//从某点开始,分别标记vis和记录该点pos
		low[i]=map[1][i];  	//第一次给low数组赋值 map的第一行 
	vis[1]=1;pos=1;t=0;
	
	for(i=1;i<n;++i)   //再运行n-1次,一次找一个最小 
	{
		MIN=INF;
		for(j=1;j<=n;++j)
		{
			if(vis[j]==0&&low[j]<MIN)
			{
				MIN=low[j];  // 找出最小值min,记录位置pos
				pos=j;
			}
		}
		sum+=MIN;
		vis[pos]=1;   //标记该点已访问 
		for(j=1;j<=n;++j)    //更新权值low 把 map的 pos 行中比对应的 low 小的赋给low 
			if(vis[j]==0&&low[j]>map[pos][j])  
				low[j]=map[pos][j];
	}
}

int main()
{
	int i,j,cas=0;
	while(scanf("%d",&n),n)
	{
		for(i=1;i<=n;++i)
			scanf("%lf%lf",&x[i],&y[i]);
	
		for(i=1;i<n;++i)   //读入数据 
		{
			for(j=i+1;j<=n;++j)
			{
				map[i][j]=map[j][i]=dlen(i,j);
			}
		}
		
		sum=0;
		prim();
		
		if(cas>0)  // 格式问题  很坑 
			printf("\n");
		printf("Case #%d:\n",++cas);
		printf("The minimal distance is: %.2lf\n",sum); //已经排过序  s[i].w即最短路径中的最长边
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值