HDOJ 1551 Cable master 【二分】

Cable master

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2726    Accepted Submission(s): 1014


Problem Description
Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter, and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
 

Input
The input consists of several testcases. The first line of each testcase contains two integer numbers N and K, separated by a space. N (1 ≤ N ≤ 10000) is the number of cables in the stock, and K (1 ≤ K ≤ 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 centimeter and at most 100 kilometers in length. All lengths in the input are written with a centimeter precision, with exactly two digits after a decimal point.

The input is ended by line containing two 0's.
 

Output
For each testcase write to the output the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output must contain the single number "0.00" (without quotes).
 

Sample Input
  
  
4 11 8.02 7.43 4.57 5.39 0 0
 

Sample Output
  
  
2.00
题目链接:  HDOJ 1551 Cable master 【二分】

题意是  有 n 根网线, 需要截成 相等的  k  根,求 最长为多少  (要注意输出的精度控制)

循环方法有 两种:第一种循环方法 ,循环 100 次  (输出用 right , mid , left  都一样)

已AC代码:

#include<cstdio>
#define M 11000
int n,k;
double s[M];

int fn(double x)  // 计算 长度为 x 时,能截多少根 
{
	int num=0,i;
	for(i=0;i<n;++i)
	{
		num += (int)(s[i]/x);
	}
	return num>=k;
}

int main()                  //二分法 
{
	int i;
	while(scanf("%d%d",&n,&k),n,k)
	{
		for(i=0;i<n;++i)
			scanf("%lf",&s[i]);
		double left=0,right=1001000,mid;
		
		int t=100;
		while(t--)   // 第一种循环方法 ,循环 100 次 
//		while(right-left>1e-10)  // 第二种 满足一定精度  输出只能用 right 
		{
			mid=(left+right)/2;
			if(fn(mid))
				left=mid;
			else
				right=mid;
		}
		double sum = (int)(mid*100)/100.0;  // 输出的精度控制
		printf("%.2f\n",sum);
	}
	return 0;
}

二分循环方法有 两种:
第一种循环方法 ,循环 100 次  (输出用 right , mid , left  都一样)

		int t=100;
		while(t--)   // 第一种循环方法 ,循环 100 次 
		{
			mid=(left+right)/2;
			if(fn(mid))
				left=mid;
			else
				right=mid;
		}
		double sum = (int)(mid*100)/100.0;  // 三个结果都一样 
//		double sum = (int)(let*100)/100.0;
//		double sum = (int)(right*100)/100.0;

第二种 满足一定精度  
(此题循环条件为(right-left>1e-10)输出只能是用 right,精度最高为 1e-10  再高就超时(1e-12 就超时))
		while(right-left>1e-10)  // 第二种 满足一定精度 
		{
			mid=(left+right)/2;
			if(fn(mid))
				left=mid;
			else
				right=mid;
		}
		double sum = (int)(right*100)/100.0;//只能用 right


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值