HDOJ1003(最大连续子串)

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2:

7 1 6

暴力解法直接超时!

#include <iostream>
#define  N 100002
using namespace std;
int main()
{
	int i = 0,j = 0,k = 0,n = 0,size = 0,begin = 0,end  = 0,count = 0,max = 0,sum = 0,index = 1;
	int a[N];
	cin>>n;
	while(n--)
	{
		max = 0;
		begin = 0;
		end = 0;
		cin>>size;
		for (i = 0;i < size;++i)
		{
		cin>>a[i];
		}
		for (int k = 0;k < size;++k)
		{
			sum = 0;
			for(j = k;j < size;++j)
			{
				sum += a[j];
				if(sum > max)
				{
					max = sum;
					begin = k;
					end = j;
				}
			}
		}
		cout<<"Case "<<index++<<":"<<endl;
		cout<<max<<" "<<begin+1<<" "<<end+1<<endl;
		if(0 != n) cout<<endl;
	}
	system("Pause");
	return 0;
}

新的方法:

#include <iostream>
using namespace std;
#define N 100000
int main()
{
	int n = 0;
	int num = 0;
	cin>>n;
	int index = 1;
	while (n--)
	{
		cin>>num;
		int temp = 0;
		int sum = 0;
		int len = 0;
		int max = -1001;
		int beg = 0;
		int end = 0;
		for (int i =1;i<=num;++i)
		{
			cin>>temp;
			sum += temp;
			len++;
			if (sum > max)
			{
				max = sum;
				beg = len;
				end = i;
			}
			if (sum < 0)
			{
				sum = 0;
				len = 0;
			}
		}
		cout<<"Case "<<index++<<":"<<endl;
		cout<<max<<" "<<end-beg+1<<" "<<end<<endl;
		if(0 != n)
			cout<<endl;
	}
	system("Pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值