yum 遇到 python运行问题

转载 2015年07月07日 07:24:55
1 SVN只打算checkout单个文件那么用命令
  svn cat http://www.iusesvn.com/project1/trunk/build.sh > build.sh

2 --现象:
-bash: /usr/bin/yum: /usr/bin/python: bad interpreter: No such file or directory

--查找python
#whereis python
python: /usr/bin/python /usr/bin/python2.4 /usr/lib/python2.4 /usr/local/bin/python2.7 /usr/local/bin/python /usr/local/bin/python2.7-config /usr/local/lib/python2.7 /usr/share/man/man1/python.1.gz

--查找yum
#whereis yum
yum: /usr/bin/yum /etc/yum.conf /etc/yum /usr/share/man/man8/yum.8.gz

--修改
#vi /usr/bin/yum
将首行的#!/usr/bin/python
更改成   #!/usr/bin/python2.4
保存退出!

解决!

    这个错误是因为python的版本不匹配,只要在/usr/bin/yum中把第一行的#!/usr/bin/python改成#!/usr /bin/python2.4就可以啦~当然,我是指路径对的情况下,毕竟通常linux下的python默认版本都是2.4,当然,例外不算。

相关文章推荐

【疑难杂症】-CentOS-修改python版本后yum运行出错

线上服务器使用的是CentOS 6.3,系统自带的python是2.6版本的,该版本的python已经很老了,企业大部分再用的python是2.7版本,而且公司编写的python爬虫使用的也是2.7版...

后台运行python程序 遇到缓冲区问题

From: http://www.iteye.com/topic/867446 环境:linux   一段执行时间很长的程序(用python做hive客户端执行mapreduce...

CentOS更新Python版本,同时修复yum不能使用的问题

发现一个新办法,那就是直接安装另一个版本的Python,比如Python3.5吧,然后把可执行文件命名为Python3,添加到环境变量里,这样在终端中输入Python3,就可以调用3.5版本的解释器了...
  • lihanx
  • lihanx
  • 2016年12月28日 11:35
  • 165

centos7安装Python3.6以及解决yum不能使用问题

Centos7默认安装了python2.7 因为一些命令要用它比如yum 它使用的是python2.7下载python3.6的包(目前最新版本是python3.6.1)在python官网下载地址进行下...

关于centos7.2 升级Python之后yum报错的问题

从昨天晚上到现在我这一直在为这件事在度娘,但是没有什么好的答案。 所以呢我就准备自己着手在看一下。果不其然通过自己的一点一点的测试果然啊是可以运行yum了,就连pip也随之弄好了。[root@hanx...

python2.7.13自动化安装脚本含pip安装配置阿里源yum问题解决

linux python 2.7.13 自动化安装脚本 包含python 2.7.13安装,pip安装,pip配置为阿里源,安装更新python后yum 问题:ImportError: No mod...
  • comprel
  • comprel
  • 2017年05月18日 00:08
  • 10079

ipython需要2.7版本python, 手动编译; 解决yum在升级python2.7版本后的功能恢复; 解决pip命令失败问题.

ipython需要python2.7版本或者更高, 所以手动编译安装. yum 基于python, 因此需要将yum的功能恢复....

安装python-devel的时候遇到yum安装报错:[is a duplicate] 重复安装

# yum install Python-devel Loaded plugins: fastestmirror, priorities Loading mirror speeds from ca...

Yum源配置

在使用yum命令的时候可能会出现以下情况: Loaded plugins: product-id, refresh-packagekit, security, subscription-manager...
  • Mr_rsq
  • Mr_rsq
  • 2017年03月31日 15:52
  • 574

CentOS7 使用 yum 安装 mysql 遇到的一个问题

在CentOS7 安装时,默认的选择数据库服务,然后又默认的使用了yum安装,却不知道从centos7开始,已经放弃了mysql,开始使用Mariadb(开源的 mysql分支) 所以别傻了~ 还.....
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:yum 遇到 python运行问题
举报原因:
原因补充:

(最多只允许输入30个字)