[HackerRank] Time Conversion

Problem

Given a time in AM/PM format, convert it to military (24-hour) time.

Input Format

A single string containing a time in 12-hour clock format.

Output Format

Convert and print the given time in 24-hour format.

Sample Input

07:05:45PM

Sample Output

19:05:45

Solution

1. using char[]

import java.io.*;
import java.util.*;

public class Solution {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        String str = in.next();
        char[] ch = str.toCharArray();
        char[] res = Arrays.copyOfRange(ch, 0, 8);

        if(ch[8] == 'A' && str.substring(0,2).equals("12")) {
            res[0] = '0';
            res[1] = '0';
        }
        else if(ch[8] =='P' && !str.substring(0,2).equals("12")) {
            String hour = "" + (Integer.parseInt(str.substring(0,2)) + 12);
            char[] h = hour.toCharArray();
            res[0] = h[0];
            res[1] = h[1];
        }
        System.out.println(res);
    }
}

2. using StringBuilder()

import java.io.*;
import java.util.*;

public class Solution {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        String str = in.next();
        char[] inChar = str.toCharArray();
        StringBuilder sb = new StringBuilder();

        if(str.charAt(8) == 'A' && str.substring(0,2).equals("12")) {
            sb.append("00");
            sb.append(str.substring(2, 8));
        }
        else if(str.charAt(8) =='P' && !str.substring(0,2).equals("12")) {

            String s = "" + (Integer.parseInt(str.substring(0,2)) + 12);
            sb.append(s);
            sb.append(str.substring(2, 8));
        }
        else sb.append(str.substring(0, 8));
        System.out.println(sb.toString());
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值