Codevs 1702 素数判定 2(Fermat定理)

1702 素数判定 2
时间限制: 1 s
空间限制: 128000 KB
题目等级 : 钻石 Diamond
传送门
题目描述 Description
一个数,他是素数么?
设他为P满足(P<=263-1)
输入描述 Input Description
P
输出描述 Output Description
Yes|No
样例输入 Sample Input
2
样例输出 Sample Output
Yes
数据范围及提示 Data Size & Hint
算法导论——数论那一节
注意Carmichael Number
分类标签 Tags
素数判定 数论

#include<iostream>
#include<cstdio>
#define LL long long
using namespace std;
LL n;
int s[]={2,3,5,7,11,13,17,19,23,29};
LL slowmi(LL a,LL b)
{
    LL tot=0;
    for(LL i=a;i;i>>=1)
    {
        if(i&1) tot=(tot+b)%n;
        b=(b+b)%n;
    }
    return tot%n;
}
LL mi(LL a,LL b)
{
    LL tot=1;
    for(LL i=a;i;i>>=1)
    {
        if(i&1) tot=slowmi(tot,b)%n;
        b=slowmi(b,b)%n;
    }
    return tot%n;
}
bool check()
{
    if(n==2) return true;
    else if(n<2||!(n&1))  return false;
    for(int i=0;i<10;i++)//费马小定理10次计算 
    {
        if(n==s[i])return true;
        if(mi(n-1,s[i])!=1) return false;
    }
    return true;
}
int main()
{
    cin>>n;
    if(check()) 
      printf("Yes");
    else printf("No");
    return 0;  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值