POJ 3278 Catch That Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 90510 Accepted: 28386

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <cctype>
#define N 100010
int Map[N*2];//判断数字有没有被访问
int n,k;
using namespace std;
struct node
{
    int x;
    int step;
};
int check(int x)
{
    if(x<0||x>N||Map[x])
        return 0;
    return 1;
}
int bfs(int t)
{
    queue<node> Q;
    node a,next;//x为当前点
    a.x=t;
    a.step=0;
    Map[t]=1;//表示当前点被访问过
    Q.push(a);//把a入队
    while(!Q.empty())
    {
        a=Q.front();
        Q.pop();//读出当前队首元素
        if(a.x==k)return a.step;
        next=a;//下一个结点的可能
        //每次都将三种状况加入队列之中
        next.x=a.x+1;
        if(check(next.x))
        {
            next.step=a.step+1;
            Map[next.x]=1;
            Q.push(next);
        }
        next.x=a.x-1;
        if(check(next.x))
        {
            next.step=a.step+1;
            Map[next.x]=1;
            Q.push(next);
        }
        next.x=a.x*2;
        if(check(next.x))
        {
            next.step=a.step+1;
            Map[next.x]=1;
            Q.push(next);
        }
    }
    return 0;//表示没有找到
}
int main()
{
    while(cin>>n>>k)
    {
        memset(Map,0,sizeof(Map));
        cout<<bfs(n)<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值