旧版本Xcode工程在Xcode4.5下真机无法调试问题的解决

原创 2012年10月23日 14:36:28

iOS6发布不久后,Xcode4.5也发布了。于是第一时间下载安装,并将之前安装的XCode删除了。后来一直用着没事,近来有个旧项目要修改有些bug,增加对iOS6和iPhone5的支持。做完该做的一切后,打算在真机上测试一下,编译成功但却无法运行。之前在模拟器上调试是一直没出现问题的。弹出的提示如下:


按往常的办法,搜索了一遍,按有些文章说的,将Deployment Target改成最低支持的4.3,之前是3.0的。修改后问题依然。

后来又尝试了好几个方法,还是不能解决。

搞了半天结果还是没有搞定,后来想想,会不会是Architectures支持的问题。项目是支持3.0以上的设备的,所以Architectures是armv6 armv7。尝试将armv6删除,换回默认值,编译运行,这下还真行。shit,搞了半天的东西,原来是这个设置问题。设置如下:


偶尔又发现了一个在Xcode下支持armv6的办法,地址如下:

http://blog.csdn.net/seamanjiang/article/details/8074456

相关文章推荐

Three20研究院之解决真机IOS6在Xcode4.5下无法编译与IOS设备自动旋转问题(九)

之前一直都是在Xcode4.4下使用Three20开发框架,今天升级到4.5了发现在IOS6下无法将程序编译到真机上,还有就是Three20在IOS6下旋转的代码全部失灵了,非常奇怪。今天抽了一点时间...

ios 解决低版本Xcode不支持高版本iOS真机调试的问题

解决低版本Xcode不支持高版本iOS真机调试的问题 原创 2017年10月26日 23:40:06 标签:iphone /xcode 518 ...

快速解决低版本Xcode不支持高版本iOS真机调试的问题

今天在进行真机调试的时候,遇到了以下问题。 Could not locate device support files. This iPhone 6s is running iOS 10.2...

解决低版本Xcode不支持高版本iOS真机调试

进行真机调试的时候,遇到了以下问题。Could not locate device support files. This iPhone 6s is running iOS 10.2(14C92),...

Xcode免证书真机调试,解决cannot read entitlement data问题

本文是根据某个帖子写的(帖子链接在最后放出),但是在配置的过程中,遇到了一个纠结的问题,这个问题折腾了我N久,一直没搞明白到底是什么原因,问题如下: 按照原帖上写的每一步去做了,但是在最后编译的时候...

xcode7-beta版本真机调试

xcode7无刀真机调试简易教程以及部分错误解决方案 1注册一个开发者账号。但是不需要99刀,xcode7以后可以不用购买就证书就可以真机调试 2 下载xcode7。 3 打开xcode7,悬着xco...
  • appleLg
  • appleLg
  • 2015年08月08日 20:16
  • 667

Xcode真机调试 - 11.1 (15B5066e)

  • 2017年11月07日 11:01
  • 5.88MB
  • 下载
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:旧版本Xcode工程在Xcode4.5下真机无法调试问题的解决
举报原因:
原因补充:

(最多只允许输入30个字)