HDOJ 2609 How many (最小表示法)

How many

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 990 Accepted Submission(s): 382


Problem Description
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').

Output
For each test case output a integer , how many different necklaces.

Sample Input
  
  
4 0110 1100 1001 0011 4 1010 0101 1000 0001

Sample Output
  
  
1 2


解题思路:

最开始的时候用暴力。即将字符串复制一遍,然后一个个查找。果断TLE...

后来用了kmp优化,还是TLE

查了资料,原来处理字符串的循环同构可以用最小表示法。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[110];
struct node
{
    char ch[110];
}st[10010];
int min_express()
{
    int len=strlen(str);
    int i=0,j=1,k=0;
    while(i<len && j<len && k<len)
    {
        int t;
        t=str[(i+k)%len]-str[(j+k)%len];
        if (t==0) k++;
        else
        {
            if (t>0) i=i+k+1;
            else j=j+k+1;
            if (i==j) j++;
            k=0;
        }
    }
    return i<j? i:j;
}
bool cmp(node a, node b)
{
    return (strcmp(a.ch, b.ch)<0);
}
int main ()
{
    int n,i,j,t=0,len;
    while (cin>>n)
    {
        for (i=0; i<n; i++)
        {
            t=0;
            scanf("%s",str);
            len=strlen(str);
            int k=min_express();
            for (j=k; j<len; j++)
                st[i].ch[t++]=str[j];
            for (j=0; j<k; j++)
                st[i].ch[t++]=str[j];
            st[i].ch[t]='\0';
        }
        sort(st,st+n,cmp);
        int sum=0;
        for (i=0; i<n-1; i++)
            if (strcmp(st[i].ch, st[i+1].ch)!=0)
                sum++;
        cout<<sum+1<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值