hdu 1385 Minimum Transport Cost (Floyd 记录路径)


Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10562    Accepted Submission(s): 2931


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17


1 23

题意:

有N个城市,给出这些城市之间的邻接矩阵,矩阵中-1代表那两个城市无道路相连,其他值代表路径长度。

如果一辆汽车经过某个城市,必须要交一定的钱(可能是过路费)。 

现在要从a城到b城,花费为路径长度之和,再加上除起点与终点外所有城市的过路费之和。

求最小花费,如果有多条路经符合,则输出字典序最小的路径。

注意字典排序 ! 


字典排序   如果123 与13 的路径相同  但是123  小于13  所以 要输出123  


下面是 代码 

 用的是floyd  后继 记录 结点 用数组顺着 输出来 

 或者 用 stack 栈 倒着输出 结点  结果也是一样的 


/*
floyd  模板   栈记录路径 wrong 导致顺 出来
 数组ac 
*/
#include<iostream>
#include<stdio.h>
#include<stack>
#include<string.h>

using namespace std;
#define  N 1000

const int inf=1<<29;

int map[N][N];
int pre[N][N];
int b[N];
int n;
void floyd()
{
	int i,j,k;
	for(k=1;k<=n;k++)
	{
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(map[i][j]>(map[i][k]+map[k][j]+b[k]))
				{
					map[i][j]=map[i][k]+map[k][j]+b[k];
					pre[i][j]=pre[i][k];//后继 
				}
				else if(map[i][j]==(map[i][k]+map[k][j]+b[k])&&pre[i][j]>pre[i][k])
						pre[i][j]=pre[i][k]; // 处理字典排序
			}
		}
	}
}
int main()
{
	int m;
	int i,j;
	while(~scanf("%d", &n),n)
	{
		memset(pre,-1,sizeof(pre));
		for(i = 1; i <= n; i ++)
		{
			for(j = 1; j <= n; j ++)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j] == -1)
					map[i][j] = inf;
				else
					pre[i][j] = j;			
			}
		}
		for(i = 1; i <= n; i ++)
			scanf("%d",&b[i]);
		floyd();
		int x,y;
//		for(i=1;i<=n;i++)
//		{
//			for(j=1;j<=n;j++)
//				printf("%d ",pre[i][j]);
//			printf("\n");			
//		}

				
		while (scanf("%d%d", &x, &y), (x != -1 || y != -1))
		{
			
//			stack<int> Q;
//			int now=pre[y][x];
//			Q.push(y);
//			while(1)
//			{
//				Q.push(now);
//				if(now== x)
//					break;
//				now=pre[now][x];
//			}
//			Q.pop();
//			printf("From %d to %d :\n",x,y);
//			printf("Path: %d",x);
//			if(x==y)
//				printf("\n");
//			else
//			{
//				while(!Q.empty())
//				{
//					printf("-->%d",Q.top());
//					Q.pop();
//				}
//				printf("\n");
//			}
//			printf("Total cost : %d\n\n",map[x][y]);
			printf("From %d to %d :\n",x,y);
			printf("Path: ");
			printf("%d",x);
			if(x == y)
				printf("\n");
			else
			{
				int next = pre[x][y]; 
				while(next != y){
					printf("-->%d",next);
					next = pre[next][y];
				}
				printf("-->%d\n",y);
			}
			printf("Total cost : %d\n\n",map[x][y]);	
		}
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值